|INSTALL.SITE(5)||File Formats Manual||INSTALL.SITE(5)|
upgrade.site — OpenBSD
installation and upgrade customization
The OpenBSD installer allows user-created sets and scripts to complement and modify the files from a default install prior to rebooting.
Like the official file sets, generic
-s).tgz sets are
tar(1) archives rooted in
/ and untarred with the
siteXY sets must be included in index.txt in order to be fetched via HTTP(S) and selectable in the installer.
If they exist and are executable, /install.site and /upgrade.site are run at the end of the install and upgrade process, respectively, with chroot(8) based at the system's root.
Create site70 sets and update the index:
# tar -czhf site70.tgz generic/ # tar -czhf site70-puffy.tgz puffy/ # ls -lT > index.txt
# cat <<- EOF >> /upgrade.site echo 'pkg_add -Iu' >>/etc/rc.firsttime EOF # chmod +x /upgrade.site # sysupgrade
|November 8, 2021||OpenBSD-current|