|HYPERV(4)||Device Drivers Manual||HYPERV(4)|
hyperv0 at pvbus?
hypervdriver performs Synthetic Interrupt Controller initialization, sets up hypercalls, and provides access to VMBus services required by paravirtualized devices such as disk and network interfaces.
An access is also provided to the Key-Value Pair exchange interface via pvbus(4). All keys are associated to one of several key pools: Auto, Guest, External or Guest/Parameters. It's possible to modify values of keys in the Auto pool as well as set new keys in the Guest pool with hostctl(8). The Host provides its read-only keys in External and Guest/Parameters pools.
hypervdriver first appeared in OpenBSD 6.1.
hypervdriver was written by Mike Belopuhov <firstname.lastname@example.org> based on the FreeBSD driver by the Microsoft BSD Integration Services Team <email@example.com>.
|September 18, 2017||OpenBSD-current|