|HVN(4)||Device Drivers Manual||HVN(4)|
hvn* at hyperv?
hvndriver provides support for a Network Virtual Service Client (NetVSC), a virtual networking interface that relays device requests to the Virtual Service Provider (VSP) in the management operating system via the VMBus.
NetVSC emulates an RNDIS 1.0 compliant device on top of a custom NVS protocol operating over the VMBus channel ring.
Individual networking interfaces can be renamed by issuing a
Rename-VMNetworkAdapter PowerShell command in the
management domain. In order to enable sending and receiving of IEEE 802.1q
(VLAN) frames, the virtual port needs to be put into Trunk
mode with the
hvndriver first appeared in OpenBSD 6.1.
hvndriver was written by Mike Belopuhov <firstname.lastname@example.org> based on the FreeBSD driver by the Microsoft BSD Integration Services Team <email@example.com>.
|October 7, 2016||OpenBSD-current|