OpenBSD manual page server

Manual Page Search Parameters

HARDCLOCK(9) Kernel Developer's Manual HARDCLOCK(9)

hardclockreal-time system clock

#include <sys/systm.h>

void
hardclock(struct clockframe *frame);

() implements the real-time system clock, interrupting hz(9) times a second. The argument frame is an opaque, machine dependent structure that encapsulates the previous machine state.

() performs a variety of time related housekeeping tasks, such as:

hardclock() is implemented in the file sys/kern/kern_clock.c.

adjtime(2), hz(9), microtime(9), spl(9), timeout(9)

June 26, 2020 OpenBSD-current