|DUMP(8)||System Manager's Manual||DUMP(8)|
dumpexamines files on a filesystem and determines which files need to be backed up. These files are copied to the given disk, tape or other storage medium for safe keeping. A dump that is larger than the output medium is broken into multiple volumes. On most media the size is determined by writing until an end-of-media indication is returned. This can be enforced by using the
dumpworks across networks, replacing the functionality of the old
dumpmay still be invoked as
rdump). See the
-foption for more on writing backups to remote hosts. Files can be marked with the “nodump” flag using chflags(1), settable only by the file's owner or the superuser. Files with this flag set will only be dumped during full backups. When set on a directory, “nodump” effectively deselects the whole subtree from being dumped, though it will still be scanned. See also the
-hoption, below. On media that cannot reliably return an end-of-media indication (such as some cartridge tape drives), each volume is of a fixed size; the actual size is determined by the tape size, density and/or block count options below. By default, the same output file name is used for each volume after prompting the operator to change media. Rewinding or ejecting tape features after a close operation on a tape device depend on the name of the tape unit device used. See the
-foption and st(4) for more information. The options are as follows:
-hoption below). A level number above 0, incremental backup, tells
dumpto copy all files new or modified since the last dump of a lower level. The default level is 0.
dumpwill constrain writes to MAXBSIZE.
TAPEenvironment variable, below. Multiple file names may be given as a single argument separated by commas. Each file will be used for one dump volume in the order listed; if the dump requires more volumes than the number of names given, the last file name will be used for all remaining volumes after prompting for media changes. If the name of the file is of the form “host:file” or “user@host:file”,
dumpwrites to the named file on the remote host using rmt(8).
dumprequires operator attention, notify all operators in the group “operator” by means similar to a wall(1).
dumpprompts for a new tape. It is recommended to be a bit conservative on this option. The default tape length is 2300 feet.
-Tflag is mutually exclusive from the
dumptells the operator what file systems need to be dumped. This information is gleaned from the files /etc/dumpdates and /etc/fstab. The
dumpto print out, for each file system in /etc/dumpdates, the most recent dump date and level, and highlights those file systems that should be dumped. If the
-Wflag is set, all other options are ignored, and
-W, but prints only those filesystems which need to be dumped.
-uis ignored, the only dump level that is supported is
-0, and all of the files must reside on the same filesystem.
dumprequires operator intervention on these conditions: end of tape, end of dump, tape write error, tape open error or disk read error (if there is more than a threshold of 32). In addition to alerting all operators implied by the
dumpinteracts with the operator on
dump's control terminal at times when
dumpcan no longer proceed, or if something is grossly wrong. All questions
dumpposes must be answered by typing “yes” or “no”, appropriately. Since making a dump involves a lot of time and effort for full dumps,
dumpcheckpoints itself at the start of each tape volume. If writing that volume fails for some reason,
dumpwill, with operator permission, restart itself from the checkpoint after the old tape has been rewound and removed, and a new tape has been mounted.
dumptells the operator what is going on at periodic intervals, including usually low estimates of the number of blocks to write, the number of tapes it will take, the time to completion, and the time to the tape change. The output is verbose, so that others know that the terminal controlling
dumpis busy, and will be for some time. If
SIGINFOsignal (see the “status” argument of stty(1)) whilst a backup is in progress, statistics on the amount completed, current transfer rate, and estimated finished time, will be written to the standard error output. In the event of a catastrophic disk event, the time required to restore all the necessary backup tapes or files to disk is dependent on the levels of the dumps taken. A few methods of staggering incremental dumps to either minimize backup effort or restore effort follow:
# /sbin/dump -0u -f /dev/nrst1 /usr/src
1 2 2 2 2 2 2
1 2 3 4 5 6 7
1 2 2 3 3 4 4
dumpexits with zero status on success. Startup errors are indicated with an exit code of 1; abnormal termination is indicated with an exit code of 3. chflags(1), stty(1), fts(3), rcmd(3), st(4), fstab(5), restore(8), rmt(8)
dumpcommand appeared in Version 4 AT&T UNIX. The 4.3BSD option syntax is implemented for backward compatibility but is not documented here.
-wflag does not report filesystems that have never been recorded in /etc/dumpdates, even if listed in /etc/fstab. When dumping a list of files or subdirectories, access privileges are required to scan the directory (as this is done via the fts(3) routines rather than directly accessing the filesystem). It would be nice if
dumpknew about the dump sequence, kept track of the tapes scribbled on, told the operator which tape to mount when, and provided more assistance for the operator running restore(8).
|October 6, 2016||OpenBSD-current|