|BOOT_ALPHA(8)||System Manager's Manual (alpha)||BOOT_ALPHA(8)|
boot_alpha — Alpha
system bootstrapping procedures
When powered on, the SRM firmware will proceed to its initialization, and will boot an operating system if the auto_action variable is set to “boot” or “restart”, or will wait for interactive commands if set to “halt”.
The SRM console will attempt to boot a kernel named from the
boot_file environment variable, on the device listed in
the bootdef_dev variable. A list of the recognized SRM
devices can be obtained with the command
show dev at
the SRM prompt. If the boot_file variable is not set or
empty, /bsd will be used by default.
The kernel will be passed the options listed in the boot_osflags variable. Option letters are case insensitive. The following option letters are recognized:
In case of system crashes, the kernel will usually enter the kernel debugger, ddb(4), unless it is not present in the kernel, or it is disabled via the ddb.panic sysctl. Upon leaving ddb, or if ddb was not entered, the kernel will halt the system if it was still in device configuration phase, or attempt a dump to the configured dump device, if possible. The crash dump will then be recovered by savecore(8) during the next multi-user boot cycle. It is also possible to force other behaviours from ddb.
Alpha Architecture Reference Manual Third Edition, Digital Press, Alpha Architecture Committee, 1998.
The device names used by OpenBSD/alpha and the SRM Console often have no relation to each other.
|January 3, 2010||OpenBSD-current|