|AST(4)||Device Drivers Manual||AST(4)|
ast — multiplexing
serial communications interface
ast0 at isa? port 0x1a0 irq 5
ast1 at isa? port 0x2a0 irq 6
com* at ast?
ast driver provides support for boards
that multiplex together up to four EIA RS-232C (CCITT V.28) communications
interfaces. Apparently the original master of hardware using this
multiplexing protocol was AST.
ast device is the master device for
up to four
com devices. The kernel configuration
com devices as slave devices of the
ast device, as shown in
SYNOPSIS. The slave ID given for each
com device determines which bit in the interrupt
multiplexing register is tested to find interrupts for that device. The port
specification for the
ast device is used to compute
the base addresses for the
com subdevices and the
port for the interrupt multiplexing register.
On a real AST card, the jumpers are as follows:
astdriver needs extended mode, so leave this OFF.
ast driver was written by Roland
McGrath and placed into the public domain.
|May 21, 2008||OpenBSD-current|