|arp(8)||address resolution display and control|
|arp(4)||Address Resolution Protocol|
|ARP(8)||System Manager's Manual||ARP(8)|
arpprogram displays and modifies the Internet-to-Ethernet address translation tables used by the address resolution protocol (ARP).
arpdisplays the current ARP entry for hostname when no optional parameters are supplied. hostname may be specified by name or by number, using Internet dot notation.
arpcan also be used to send Wake on LAN (WoL) frames over a local Ethernet network to one or more hosts using their link layer (hardware) addresses. WoL functionality is generally enabled in a machine's BIOS and can be used to power on machines from a remote system without having physical access to them. The options are as follows:
-doption below. The following information will be printed:
-dflag may be combined with the
-aflag to delete all entries, with hostname lookups automatically disabled. Only the superuser may delete entries.
-soption for a description of the file format and the effect of the
arpattempts to display addresses symbolically).
-shostname ether_addr [
tempis given in the command. A static ARP entry can be overwritten by network traffic, unless the word
permanentis given. If the word
pubis given, the entry will be “published”; that is, this system will act as an ARP server, responding to requests for hostname even though the host address is not its own. This behavior has traditionally been called proxy ARP. If the entry already exists for the given host, it will not be replaced unless
$ arp -a
# arp -s 10.0.0.2 00:90:27:bb:cc:dd permanent
# arp -s 188.8.131.52 00:90:27:bb:cc:dd pub # arp -s 184.108.40.206 00:90:27:bb:cc:dd pub
arpcommand appeared in 4.3BSD. Wake on LAN functionality was added in OpenBSD 4.9.
|April 5, 2016||OpenBSD-current|