OpenBSD manual page server

Manual Page Search Parameters
INTR_BARRIER(9) Kernel Developer's Manual INTR_BARRIER(9)

intr_barrierinterrupt barrier

#include <machine/intr.h>

void
intr_barrier(void *ih);

This function guarantees that any interrupt handler invocations for the interrupt handler specified by ih has finished before it returns. The cookie passed to () should be the value returned when the interrupt handler was established, for example the return value of pci_intr_establish(9).

intr_barrier() can be called from process context.

pci_intr_establish(9), spl(9)

September 13, 2015 OpenBSD-current