|VMD(8)||System Manager's Manual||VMD(8)|
vmdis a daemon responsible for the execution of virtual machines (VMs) on a host.
vmdis typically started at boot time and is controlled via vmctl(8).
vmdcan be enabled during system boot by setting the following in /etc/rc.conf.local:
vmdinterfaces with the virtual machine monitor (VMM) built into the kernel. One instance of
vmdwill be spawned for each VM running on the host, plus extra instances for control operations. Each child
vmdwill in turn create one or more VCPU (virtual CPU) threads responsible for driving the VM's operations using vmm(4).
vmdis also responsible for proxying various other commands/requests from vmctl(8), such as stopping VMs, and retrieving information from vmm(4) about running VMs. The options are as follows:
-voptions increase the verbosity.
vmdcommand first appeared in OpenBSD 5.9. Mike Larkin <firstname.lastname@example.org> and
|July 19, 2017||OpenBSD-current|