|SSHD(8)||System Manager's Manual||SSHD(8)|
sshd(OpenSSH Daemon) is the daemon program for ssh(1). Together these programs replace rlogin and rsh, and provide secure encrypted communications between two untrusted hosts over an insecure network.
sshdlistens for connections from clients. It is normally started at boot from /etc/rc. It forks a new daemon for each incoming connection. The forked daemons handle key exchange, encryption, authentication, command execution, and data exchange.
sshdcan be configured using command-line options or a configuration file (by default sshd_config(5)); command-line options override values specified in the configuration file.
sshdrereads its configuration file when it receives a hangup signal,
SIGHUP, by executing itself with the name and options it was started with, e.g. /usr/sbin/sshd. The options are as follows:
sshdto use IPv4 addresses only.
sshdto use IPv6 addresses only.
-Textended test mode. If provided, any
Matchdirectives in the configuration file that would apply are applied before the configuration is written to standard output. The connection parameters are supplied as keyword=value pairs and may be supplied in any order, either with multiple
-Coptions or as a comma-separated list. The keywords are “addr,” “user”, “host”, “laddr”, “lport”, and “rdomain” and correspond to source address, user, resolved source host name, local address, local port number and routing domain respectively.
sshdduring key exchange. The certificate file must match a host key file specified using the
-hoption or the
sshdwill not detach and does not become a daemon. This allows easy monitoring of
-doptions increase the debugging level. Maximum is 3.
sshdrefuses to start if there is no configuration file.
sshdis not run as root (as the normal host key files are normally not readable by anyone but root). The default is /etc/ssh/ssh_host_ecdsa_key, /etc/ssh/ssh_host_ed25519_key and /etc/ssh/ssh_host_rsa_key. It is possible to have multiple host key files for the different host key algorithms.
sshdis being run from inetd(8).
Portoption are ignored when a command-line port is specified. Ports specified using the
ListenAddressoption override command-line ports.
Matchrules may be applied by specifying the connection parameters using one or more
sshdreliably as configuration options may change.
utmpstructure that holds the remote host name. If the resolved host name is longer than len, the dotted decimal value will be used instead. This allows hosts with very long host names that overflow this field to still be uniquely identified. Specifying
-u0indicates that only dotted decimal addresses should be put into the utmp file.
-u0may also be used to prevent
sshdfrom making DNS requests unless the authentication mechanism or configuration requires it. Authentication mechanisms that may require DNS include
HostbasedAuthenticationand using a
from="pattern-list"option in a key file. Configuration options that require DNS include using a USER@HOST pattern in
sshddoes the following:
PermitUserEnvironmentoption in sshd_config(5).
PermitUserRCoption is set, runs it; else if /etc/ssh/sshrc exists, runs it; otherwise runs xauth. The “rc” files are given the X11 authentication protocol and cookie in standard input. See SSHRC, below.
DISPLAYin its environment). The script must call xauth(1) because
sshdwill not run xauth automatically to add X11 cookies. The primary purpose of this file is to run any initialization routines which may be needed before the user's home directory becomes accessible; AFS is a particular example of such an environment. This file will probably contain some initialization code followed by something similar to:
if read proto cookie && [ -n "$DISPLAY" ]; then if [ `echo $DISPLAY | cut -c1-10` = 'localhost:' ]; then # X11UseLocalhost=yes echo add unix:`echo $DISPLAY | cut -c11-` $proto $cookie else # X11UseLocalhost=no echo add $DISPLAY $proto $cookie fi | xauth -q - fi
AuthorizedKeysFilespecifies the files containing public keys for public key authentication; if this option is not specified, the default is ~/.ssh/authorized_keys and ~/.ssh/authorized_keys2. Each line of the file contains one key (empty lines and lines starting with a ‘
#’ are ignored as comments). Public keys consist of the following space-separated fields: options, keytype, base64-encoded key, comment. The options field is optional. The keytype is “ecdsa-sha2-nistp256”, “ecdsa-sha2-nistp384”, “ecdsa-sha2-nistp521”, “ssh-ed25519”, “ssh-dss” or “ssh-rsa”; the comment field is not used for anything (but may be convenient for the user to identify the key). Note that lines in this file can be several hundred bytes long (because of the size of the public key encoding) up to a limit of 8 kilobytes, which permits DSA keys up to 8 kilobits and RSA keys up to 16 kilobits. You don't want to type them in; instead, copy the id_dsa.pub, id_ecdsa.pub, id_ed25519.pub, or the id_rsa.pub file and edit it.
sshdenforces a minimum RSA key modulus size of 1024 bits. The options (if present) consist of comma-separated option specifications. No spaces are permitted, except within double quotes. The following option specifications are supported (note that option keywords are case-insensitive):
no-pty. A quote may be included in the command by quoting it with a backslash. This option might be useful to restrict certain public keys to perform just a specific operation. An example might be a key that permits remote backups but nothing else. Note that the client may specify TCP and/or X11 forwarding unless they are explicitly prohibited, e.g. using the
restrictkey option. The command originally supplied by the client is available in the
SSH_ORIGINAL_COMMANDenvironment variable. Note that this option applies to shell, command or subsystem execution. Also note that this command may be superseded by a sshd_config(5)
ForceCommanddirective. If a command is specified and a forced-command is embedded in a certificate used for authentication, then the certificate will be accepted only if the two commands are identical.
fromstanza may match IP addresses using CIDR address/masklen notation. The purpose of this option is to optionally increase security: public key authentication by itself does not trust the network or name servers or anything (but the key); however, if somebody somehow steals the key, the key permits an intruder to log in from anywhere in the world. This additional option makes using a stolen key more difficult (name servers and/or routers would have to be compromised in addition to just the key).
-Roption such that it may only listen on the specified host (optional) and port. IPv6 addresses can be specified by enclosing the address in square brackets. Multiple
permitlistenoptions may be applied separated by commas. Hostnames may include wildcards as described in the PATTERNS section in ssh_config(5). A port specification of
*matches any port. Note that the setting of
GatewayPortsmay further restrict listen addresses. Note that ssh(1) will send a hostname of “localhost” if a listen host was not specified when the forwarding was requested, and that this name is treated differently to the explicit localhost addresses “127.0.0.1” and “::1”.
-Loption such that it may only connect to the specified host and port. IPv6 addresses can be specified by enclosing the address in square brackets. Multiple
permitopenoptions may be applied separated by commas. No pattern matching is performed on the specified hostnames, they must be literal domains or addresses. A port specification of
*matches any port.
cert-authorityline, specifies allowed principals for certificate authentication as a comma-separated list. At least one name from the list must appear in the certificate's list of principals for the certificate to be accepted. This option is ignored for keys that are not marked as trusted certificate signers using the
# Comments allowed at start of line ssh-rsa AAAAB3Nza...LiPk== firstname.lastname@example.org from="*.sales.example.net,!pc.sales.example.net" ssh-rsa AAAAB2...19Q== email@example.com command="dump /home",no-pty,no-port-forwarding ssh-rsa AAAAC3...51R== example.net permitopen="192.0.2.1:80",permitopen="192.0.2.2:25" ssh-rsa AAAAB5...21S== permitlisten="localhost:8080",permitopen="localhost:22000" ssh-rsa AAAAB5...21S== tunnel="0",command="sh /etc/netstart tun0" ssh-rsa AAAA...== firstname.lastname@example.org restrict,command="uptime" ssh-rsa AAAA1C8...32Tv== email@example.com restrict,pty,command="nethack" ssh-rsa AAAA1f8...IrrC5== firstname.lastname@example.org
*’ and ‘
?’ act as wildcards); each pattern in turn is matched against the host name. When
sshdis authenticating a client, such as when using
HostbasedAuthentication, this will be the canonical client host name. When ssh(1) is authenticating a server, this will be the host name given by the user, the value of the ssh(1)
HostkeyAliasif it was specified, or the canonical server hostname if the ssh(1)
CanonicalizeHostnameoption was used. A pattern may also be preceded by ‘
!’ to indicate negation: if the host name matches a negated pattern, it is not accepted (by that line) even if it matched another pattern on the line. A hostname or address may optionally be enclosed within ‘
[’ and ‘
]’ brackets then followed by ‘
:’ and a non-standard port number. Alternately, hostnames may be stored in a hashed form which hides host names and addresses should the file's contents be disclosed. Hashed hostnames start with a ‘
|’ character. Only one hashed hostname may appear on a single line and none of the above negation or wildcard operators may be applied. The keytype and base64-encoded key are taken directly from the host key; they can be obtained, for example, from /etc/ssh/ssh_host_rsa_key.pub. The optional comment field continues to the end of the line, and is not used. Lines starting with ‘
#’ and empty lines are ignored as comments. When performing host authentication, authentication is accepted if any matching line has the proper key; either one that matches exactly or, if the server has presented a certificate for authentication, the key of the certification authority that signed the certificate. For a key to be trusted as a certification authority, it must use the “@cert-authority” marker described above. The known hosts file also provides a facility to mark keys as revoked, for example when it is known that the associated private key has been stolen. Revoked keys are specified by including the “@revoked” marker at the beginning of the key line, and are never accepted for authentication or as certification authorities, but instead will produce a warning from ssh(1) when they are encountered. It is permissible (but not recommended) to have several lines or different host keys for the same names. This will inevitably happen when short forms of host names from different domains are put in the file. It is possible that the files contain conflicting information; authentication is accepted if valid information can be found from either file. Note that the lines in these files are typically hundreds of characters long, and you definitely don't want to type in the host keys by hand. Rather, generate them by a script, ssh-keyscan(1) or by taking, for example, /etc/ssh/ssh_host_rsa_key.pub and adding the host names at the front. ssh-keygen(1) also offers some basic automated editing for ~/.ssh/known_hosts including removing hosts matching a host name and converting all host names to their hashed representations. An example ssh_known_hosts file:
# Comments allowed at start of line closenet,...,192.0.2.53 1024 37 159...93 closenet.example.net cvs.example.net,192.0.2.10 ssh-rsa AAAA1234.....= # A hashed hostname |1|JfKTdBh7rNbXkVAQCRp4OQoPfmI=|USECr3SWf1JUPsms5AqfD5QfxkM= ssh-rsa AAAA1234.....= # A revoked key @revoked * ssh-rsa AAAAB5W... # A CA key, accepted for any host in *.mydomain.com or *.mydomain.org @cert-authority *.mydomain.org,*.mydomain.com ssh-rsa AAAAB5W...
PrintMotd, respectively, are enabled. It does not suppress printing of the banner specified by
sshdreads it as root. Additionally, this file must be owned by the user, and must not have write permissions for anyone else. The recommended permission for most machines is read/write for the user, and not accessible by others.
sshdwill not allow it to be used unless the
StrictModesoption has been set to “no”.
#’), and assignment lines of the form name=value. The file should be writable only by the user; it need not be readable by anyone else. Environment processing is disabled by default and is controlled via the
sshdrefuses to let anyone except root log in. The contents of the file are displayed to anyone trying to log in, and non-root connections are refused. The file should be world-readable.
sshddoes not start if these files are group/world-accessible.
sshd. The file format and configuration options are described in sshd_config(5).
sshdduring privilege separation in the pre-authentication phase. The directory should not contain any files and must be owned by root and not group or world-writable.
sshdlistening for connections (if there are several daemons running concurrently for different ports, this contains the process ID of the one started last). The content of this file is not sensitive; it can be world-readable.
|July 22, 2018||OpenBSD-current|