|SENSORSD(8)||System Manager's Manual||SENSORSD(8)|
sensorsdutility retrieves sensor monitoring data like fan speed, temperature, voltage and RAID logical disk status from the sysctl(2) hw.sensors subtree. When the state of any monitored sensor changes, an alert is triggered. Every alert logs a message to syslog(3) using the
daemonfacility. Optionally, an alert can be configured to execute a command. By default,
sensorsdmonitors status changes on all sensors that keep their state, thus sensors that automatically provide status do not require any additional configuration. In addition, for every sensor, no matter whether it automatically provides its state or not, custom low and high limits may be set, so that a local notion of sensor status can be computed by
sensorsd, indicating whether the sensor is within or is exceeding its limits. Limit and command values for a particular sensor may be specified in the sensorsd.conf(5) configuration file. This file is reloaded upon receiving
SIGHUP. The options are as follows:
sensorsdwill run in the foreground.
sensorsdprogram first appeared in OpenBSD 3.5.
sensorsdrequires two confirmations before reporting a state change. However, this inevitably introduces an additional delay in status reporting and command execution, e.g. one may notice that
sensorsdmakes its initial report about the state of monitored sensors not immediately, but by default about 60 seconds after it is started.
|January 12, 2018||OpenBSD-current|