|OWSBM(4)||Device Drivers Manual||OWSBM(4)|
owsbm* at onewire?
owsbmdriver provides support for the 1-Wire smart battery monitor. The sensor possesses a temperature sensor, an A/D converter for measuring both battery voltage and current, a current accumulator of both incoming and outgoing current, an elapsed time and 40 bytes of nonvolatile EEPROM.
Only the three voltages (VDD, VAD, CR) and temperature are accessible by the sysctl(8) interface.
The following chips are supported by the driver:
I = Voltage CR / Rsens (where Rsens is in Ohms)
owsbmdriver first appeared in OpenBSD 4.1.
owsbmdriver was written by Aaron Linville <firstname.lastname@example.org>.
|July 16, 2013||OpenBSD-current|