OpenBSD manual page server

Manual Page Search Parameters

IEEE80211_ENCAP(9) Kernel Developer's Manual IEEE80211_ENCAP(9)

ieee80211_encap, ieee80211_add_rates, ieee80211_add_xrates, ieee80211_send_mgmtsoftware 802.11 stack output functions

#include <net80211/ieee80211_var.h>
#include <net80211/ieee80211_proto.h>

struct mbuf *
ieee80211_encap(struct ifnet *ifp, struct mbuf *m, struct ieee80211_node **pni);

u_int8_t *
ieee80211_add_rates(u_int8_t *frm, const struct ieee80211_rateset *rs);

u_int8_t *
ieee80211_add_xrates(u_int8_t *frm, const struct ieee80211_rateset *rs);

int
ieee80211_send_mgmt(struct ieee80211com *ic, struct ieee80211_node *ni, int type, int arg);

These functions handle the encapsulation and transmission of 802.11 frames within the software 802.11 stack.

The () function encapsulates an outbound data frame contained within the mbuf chain m from the interface ifp. The argument *pni is a reference to the destination node.

If the function is successful, the mbuf chain is updated with the 802.11 frame header prepended, and a pointer to the head of the chain is returned. If an error occurs, NULL will be returned, and *pni is also set to NULL. The caller is responsible for freeing the node reference if *pni is non-NULL on return. The convention is that ic_bss is not reference counted; the caller is responsible for maintaining this reference count.

The () utility function is used to add the rate set element *rs to the frame frm. A pointer to the location in the buffer after the addition of the rate set is returned. It is typically used when constructing management frames from within the software 802.11 stack.

The () utility function is used to add the extended rate set element *rs to the frame frm. A pointer to the location in the buffer after the addition of the rate set is returned. It is typically used when constructing management frames from within the software 802.11 stack in 802.11g mode.

The () function transmits a management frame on the interface ic to the destination node ni of type type.

The argument arg specifies either a sequence number for authentication operations, a status code for [re]association operations, or a reason for deauthentication and deassociation operations.

Nodes other than ic_bss have their reference count incremented to reflect their use for an indeterminate amount of time. This reference is freed when the function returns.

The function returns 0 if successful; if temporary buffer space is not available, the function returns ENOMEM.

ieee80211(9)

The ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6 and OpenBSD 3.6.

This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>.

November 23, 2015 OpenBSD-7.1