OpenBSD manual page server

Manual Page Search Parameters

PCAP-FILTER(5) File Formats Manual PCAP-FILTER(5)

pcap-filterpacket filter syntax

pcap_compile(3) compiles pcap filters for software such as tcpdump(8). The resulting filter program can then be applied to some stream of packets to determine which packets will be supplied to pcap_loop(3), pcap_dispatch(3), pcap_next(3), or pcap_next_ex(3).

The filter expression consists of one or more . Primitives usually consist of an id (name or number) preceded by one or more qualifiers. There are three different kinds of qualifier:

type
Specify which kind of address component the id name or number refers to. Possible types are host, net and port. E.g., “host foo”, “net 128.3”, “port 20”. If there is no type qualifier, host is assumed.
dir
Specify a particular transfer direction to and/or from id. Possible directions are src, dst, src or dst, src and dst, ra, ta, addr1, addr2, addr3, and addr4. E.g., “src foo”, “dst net 128.3”, “src or dst port ftp-data”. If there is no dir qualifier, src or dst is assumed. The ra, ta, addr1, addr2, addr3, and addr4 qualifiers are only valid for IEEE 802.11 Wireless LAN link layers. For null link layers (i.e., point-to-point protocols such as SLIP (Serial Line Internet Protocol) or the pflog(4) header), the inbound and outbound qualifiers can be used to specify a desired direction.
proto
Restrict the match to a particular protocol. Possible protocols are: ah, arp, atalk, decnet, esp, ether, fddi, icmp, icmp6, igmp, igrp, ip, ip6, lat, mopdl, moprc, pim, rarp, sca, stp, tcp, udp, and wlan. E.g., “ether src foo”, “arp net 128.3”, “tcp port 21”, and “wlan addr2 0:2:3:4:5:6”. If there is no protocol qualifier, all protocols consistent with the type are assumed. E.g., “src foo” means “(ip or arp or rarp) src foo” (except the latter is not legal syntax); “net bar” means “(ip or arp or rarp) net bar”; and “port 53” means “(TCP or UDP) port 53”.

fddi is actually an alias for ether; the parser treats them identically as meaning "the data link level used on the specified network interface". FDDI (Fiber Distributed Data Interface) headers contain Ethernet-like source and destination addresses, and often contain Ethernet-like packet types, so it's possible to filter these FDDI fields just as with the analogous Ethernet fields. FDDI headers also contain other fields, but they cannot be named explicitly in a filter expression.

Similarly, tr and wlan are aliases for ether; the previous paragraph's statements about FDDI headers also apply to Token Ring and 802.11 wireless LAN headers. For 802.11 headers, the destination address is the DA field and the source address is the SA field; the BSSID, RA, and TA fields aren't tested.

In addition to the above, there are some special primitive keywords that don't follow the pattern: gateway, broadcast, less, greater, and arithmetic expressions. All of these are described below.

More complex filter expressions are built up by using the words and, or, and not to combine primitives e.g., “host foo and not port ftp and not port ftp-data”. To save typing, identical qualifier lists can be omitted e.g., “tcp dst port ftp or ftp-data or domain” is exactly the same as “tcp dst port ftp or tcp dst port ftp-data or tcp dst port domain”.

Allowable primitives are:

host
True if the IPv4/v6 destination field of the packet is host, which may be either an address or a name.
host
True if the IPv4/v6 source field of the packet is host.
host
True if either the IPv4/v6 source or destination of the packet is host.

Any of the above host expressions can be prepended with the keywords, ip, arp, rarp, or ip6, as in:

ip host host

which is equivalent to:

ether proto ip and host host

If host is a name with multiple IP addresses, each address will be checked for a match.

ehost
True if the Ethernet destination address is ehost. ehost may be either a name from /etc/ethers or a number (see ether_aton(3) for a numeric format).
ehost
True if the Ethernet source address is ehost.
ehost
True if either the Ethernet source or destination address is ehost.
host
True if the packet used host as a gateway; i.e., the Ethernet source or destination address was host but neither the IP source nor the IP destination was host. host must be a name and must be found both by the machine's host-name-to-IP-address resolution mechanisms (host name file, DNS, NIS, etc.) and by the machine's host-name-to-Ethernet-address resolution mechanism (such as /etc/ethers). An equivalent expression is:
ether host ehost and not host host

which can be used with either names or numbers for host/ehost. This syntax does not work in an IPv6-enabled configuration at this moment.

net
True if the IPv4/v6 destination address of the packet has a network number of net, which may be either a name from the networks database (such as /etc/networks) or a network number. An IPv4 network number can be written as a dotted quad (e.g. 192.168.1.0), dotted triple (e.g. 192.168.1), dotted pair (e.g 172.16), or single number (e.g. 10); the netmask is 255.255.255.255 for a dotted quad (which means that it's really a host match), 255.255.255.0 for a dotted triple, 255.255.0.0 for a dotted pair, or 255.0.0.0 for a single number. An IPv6 network number must be written out fully; the netmask is ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, so IPv6 "network" matches are really always host matches, and a network match requires a netmask length.
net
True if the IPv4/v6 source address of the packet has a network number of net.
net
True if either the IPv4/v6 source or destination address of the packet has a network number of net.
net mask netmask
True if the IPv4 address matches net with the specific netmask. May be qualified with src or dst. Note that this syntax is not valid for IPv6 networks.
net/len
True if the IPv4/v6 address matches net with a netmask len bits wide. May be qualified with src or dst.
port
True if the packet is IP/TCP, IP/UDP, IP6/TCP or IP6/UDP and has a destination port value of port. The port can be a number or a name used in /etc/services (see tcp(4) and udp(4)). If a name is used, both the port number and protocol are checked. If a number or ambiguous name is used, only the port number is checked (e.g. “dst port 513” will print both TCP/login traffic and UDP/who traffic, and “port domain” will print both TCP/domain and UDP/domain traffic).
port
True if the packet has a source port value of port.
port
True if either the source or destination port of the packet is port.

Any of the above port expressions can be prepended with the keywords tcp or udp, as in:

tcp src port port

which matches only TCP packets whose source port is port.

length
True if the packet has a length less than or equal to length. This is equivalent to:

len <= length
length
True if the packet has a length greater than or equal to length. This is equivalent to:

len >= length
samplerate
True if the packet has been randomly selected or sampled at a rate of 1 per samplerate.
protocol
True if the packet is an IPv4 packet (see ip(4)) of protocol type protocol. protocol can be a number, or one of the names from protocols(5), such as icmp, icmp6, igmp, igrp, pim, ah, esp, vrrp, udp, or tcp. Note that the identifiers tcp, udp, and icmp are also keywords and must be escaped using a backslash character (\). Note that this primitive does not chase the protocol header chain.
protocol
True if the packet is an IPv6 packet of protocol type protocol. Note that this primitive does not chase the protocol header chain.
True if the packet is an Ethernet broadcast packet. The ether keyword is optional.
True if the packet is an IPv4 broadcast packet. It checks for both the all-zeroes and all-ones broadcast conventions, and looks up the subnet mask on the interface on which the capture is being done.

If the subnet mask of the interface on which the capture is being done is not known, a value of PCAP_NETMASK_UNKNOWN can be supplied; tests for IPv4 broadcast addresses will fail to compile, but all other tests in the filter program will be OK.

True if the packet is an Ethernet multicast packet. The ether keyword is optional. This is shorthand for “ether[0] & 1 != 0”.
True if the packet is an IPv4 multicast packet.
True if the packet is an IPv6 multicast packet.
protocol
True if the packet is of ether type protocol. protocol can be a number, or one of the names ip, ip6, arp, rarp, atalk, atalkarp, decnet, decdts, decdns, lanbridge, lat, mopdl, moprc, pup, sca, sprite, stp, vexp, vprod, or xns. These identifiers are also keywords and must be escaped using a backslash character (‘\’).

In the case of FDDI (e.g., “fddi protocol arp”), and IEEE 802.11 wireless LANS (such as “wlan protocol arp”), for most of those protocols the protocol identification comes from the 802.2 Logical Link Control (LLC) header, which is usually layered on top of the FDDI or 802.11 header.

When filtering for most protocol identifiers on FDDI or 802.11, the filter checks only the protocol ID field of an LLC header in so-called SNAP format with an Organizational Unit Identifier (OUI) of 0x000000, for encapsulated Ethernet; it doesn't check whether the packet is in SNAP format with an OUI of 0x000000. The exceptions are:

iso
The filter checks the DSAP (Destination Service Access Point) and SSAP (Source Service Access Point) fields of the LLC header.
stp
The filter checks the DSAP of the LLC header.
atalk
The filter checks for a SNAP-format packet with an OUI of 0x080007 and the AppleTalk etype.

In the case of Ethernet, the filter checks the Ethernet type field for most of those protocols. The exceptions are:

iso and stp
The filter checks for an 802.3 frame and then checks the LLC header as it does for FDDI and 802.11.
atalk
The filter checks both for the AppleTalk etype in an Ethernet frame and for a SNAP-format packet as it does for FDDI, Token Ring, and 802.11.
host
True if the DECNET source address is host, which may be an address of the form “10.123”, or a DECNET host name. DECNET host name support is only available on systems that are configured to run DECNET.
host
True if the DECNET destination address is host.
host
True if either the DECNET source or destination address is host.
interface
True if the packet was logged as coming from the specified interface (applies only to packets logged by pf(4)).
interface
Synonymous with the ifname modifier.
num
True if the packet was logged as matching the specified PF rule number in the main ruleset (applies only to packets logged by pf(4)).
num
Synonymous with the rnr modifier.
code
True if the packet was logged with the specified PF reason code. Known codes are: match, bad-offset, fragment, short, normalize, memory, bad-timestamp, congestion, ip-option, proto-cksum, state-mismatch, state-insert, state-limit, src-limit, and synproxy (applies only to packets logged by pf(4)).
name
True if the packet was logged as matching the specified PF ruleset name of an anchored ruleset (applies only to packets logged by pf(4)).
name
Synonymous with the rset modifier.
num
True if the packet was logged as matching the specified PF rule number of an anchored ruleset (applies only to packets logged by pf(4)).
num
Synonymous with the srnr modifier.
act
True if PF took the specified action when the packet was logged. Known actions are: pass and block, nat, rdr, binat, match and scrub (applies only to packets logged by pf(4)).
, ip6, arp, rarp, atalk, decnet, iso, stp
Abbreviations for ether proto p, where p is one of the above protocols.
, moprc, mopdl
Abbreviations for ether proto p, where p is one of the above protocols. Note that not all applications using pcap_open_live(3) currently know how to parse these protocols (ie. tcpdump(8)).
, esp, icmp, icmp6, igmp, igrp, pim, tcp, udp
Abbreviations for ip proto p or ip6 proto p, where p is one of the above protocols.
ehost
True if the first IEEE 802.11 address is ehost.
ehost
True if the second IEEE 802.11 address is ehost.
ehost
True if the third IEEE 802.11 address is ehost.
ehost
True if the fourth IEEE 802.11 address is ehost. The fourth address field is only used for WDS (Wireless Distribution System) frames.
ehost
True if either the first, second, third, or fourth IEEE 802.11 address is ehost.
wlan_type
True if the IEEE 802.11 frame type matches the specified wlan_type. Valid types are: mgt, ctl, data, or a numeric value.
wlan_type subtype wlan_subtype
True if the IEEE 802.11 frame type matches the specified wlan_type and frame subtype matches the specified wlan_subtype.

If the specified wlan_type is mgtv, then valid values for wlan_subtype are assoc-req, assoc-resp, reassoc-req, reassoc-resp, probe-req, probe-resp, beacon, atim, disassoc, auth, and deauth.

If the specified wlan_type is ctl, then valid values for wlan_subtype are ps-poll, rts, cts, ack, cf-end, and cf-end-ack.

If the specified wlan_type is data, then valid values for wlan_subtype are data, data-cf-ack, data-cf-poll, data-cf-ack-poll, null, cf-ack, cf-poll, cf-ack-poll, qos-data, qos-data-cf-ack, qos-data-cf-poll, qos-data-cf-ack-poll, qos, qos-cf-poll, and qos-cf-ack-poll.

wlan_subtype
True if the IEEE 802.11 frame subtype matches the specified wlan_subtype and frame has the type to which the specified wlan_subtype belongs.
dir
True if the IEEE 802.11 frame direction matches the specified dir. Valid directions are: nods, tods, fromds, dstods, or a numeric value.
[vlan_id]
True if the packet is an IEEE 802.1Q VLAN packet. If vlan_id is specified, only true if the packet has the specified ID. Note that the first vlan keyword encountered in expression changes the decoding offsets for the remainder of expression on the assumption that the packet is a VLAN packet. This expression may be used more than once, to filter on VLAN hierarchies. Each use of that expression increments the filter offsets by 4.

For example, to filter on VLAN 200 encapsulated within VLAN 100:

vlan 100 && vlan 200

To filter IPv4 protocols encapsulated in VLAN 300 encapsulated within any higher order VLAN:

vlan && vlan 300 && ip
[label]
True if the packet is an MPLS (Multi-Protocol Label Switching) packet. If label is specified, only true if the packet has the specified label. Note that the first mpls keyword encountered in expression changes the decoding offsets for the remainder of expression on the assumption that the packet is an MPLS packet. This expression may be used more than once, to filter on MPLS labels. Each use of that expression increments the filter offsets by 4.

For example, to filter on MPLS label 42 first and requires the next label to be 12:

mpls 42 && mpls 12

To filter on network 192.0.2.0/24 transported inside packets with label 42:

mpls 42 && net 192.0.2.0/24
expr relop expr
True if the relation holds, where relop is one of ‘>’, ‘<’, ‘>=’, ‘<=’, ‘=’, ‘!=’, and expr is an arithmetic expression composed of integer constants (expressed in standard C syntax), the normal binary operators (‘+’, ‘-’, ‘*’, ‘/’, ‘&’, ‘|’, ‘<<’, ‘>>’), a length operator, a random operator, and special packet data accessors. Note that all comparisons are unsigned, so that, for example, 0x80000000 and 0xffffffff are > 0. To access data inside the packet, use the following syntax:

proto[expr:size]

proto is one of ether, fddi, tr, wlan, ppp, slip, link, ip, arp, rarp, tcp, udp, icmp, ip6, or radio, and indicates the protocol layer for the index operation (ether, fddi, wlan, tr, ppp, slip, and link all refer to the link layer; radio refers to the "radio header" added to some 802.11 captures). Note that tcp, udp, and other upper-layer protocol types only apply to IPv4, not IPv6 (this will be fixed in the future). The byte offset, relative to the indicated protocol layer, is given by expr. size is optional and indicates the number of bytes in the field of interest; it can be either one, two, or four, and defaults to one. The length operator, indicated by the keyword len, gives the length of the packet. The random operator, indicated by the keyword random, generates a random number.

For example, “ether[0] & 1 != 0” catches all multicast traffic. The expression “ip[0] & 0xf != 5” catches all IPv4 packets with options. The expression “ip[6:2] & 0x1fff = 0” catches only unfragmented IPv4 datagrams and frag zero of fragmented IPv4 datagrams. This check is implicitly applied to the tcp and udp index operations. For instance, “tcp[0]” always means the first byte of the TCP header, and never means the first byte of an intervening fragment.

Some offsets and field values may be expressed as names rather than as numeric values. The following protocol header field offsets are available: icmptype (ICMP type field), icmpcode (ICMP code field), and tcpflags (TCP flags field).

The following ICMP type field values are available: icmp-echoreply, icmp-unreach, icmp-sourcequench, icmp-redirect, icmp-echo, icmp-routeradvert, icmp-routersolicit, icmp-timxceed, icmp-paramprob, icmp-tstamp, icmp-tstampreply, icmp-ireq, icmp-ireqreply, icmp-maskreq, and icmp-maskreply.

The following TCP flags field values are available: tcp-fin, tcp-syn, tcp-rst, tcp-push, tcp-ack, tcp-urg.

Primitives may be combined using a parenthesized group of primitives and operators. Parentheses are special to the shell and must be escaped. Allowable primitives and operators are:

Negation (“!” or “not”)

Concatenation (“&&” or “and”)

Alternation (“||” or “or”)

Negation has highest precedence. Alternation and concatenation have equal precedence and associate left to right. Explicit and tokens, not juxtaposition, are now required for concatenation.

If an identifier is given without a keyword, the most recent keyword is assumed. For example, For example,

not host vs and ace

is short for

not host vs and host ace

which should not be confused with

not (host vs or ace)

To select all packets arriving at or departing from “sundown”:

host sundown

To select traffic between “helios” and either “hot” or “ace”:

host helios and \( hot or ace \)

To select all IP packets between “ace” and any host except “helios”:

ip host ace and not helios

To select all traffic between local hosts and hosts at Berkeley:

net ucb-ether

To select all FTP traffic through internet gateway “snup”:

gateway snup and (port ftp or ftp-data)

To select traffic neither sourced from nor destined for local network 192.168.7.0/24 (if you gateway to one other net, this stuff should never make it onto your local net):

ip and not net 192.168.7.0/24

To select the start and end packets (the SYN and FIN packets) of each TCP connection that involves a host not in local network 192.168.7.0/24:

tcp[tcpflags] & (tcp-syn|tcp-fin) != 0 and not src and dst \
	net 192.168.7.0/24

To select all IPv4 HTTP packets to and from port 80, i.e. print only packets that contain data and not, for example, SYN and FIN packets and ACK-only packets (IPv6 is left as an exercise for the reader):

tcp port 80 and (((ip[2:2] - ((ip[0]&0xf)<<2)) \
	- ((tcp[12]&0xf0)>>2)) != 0)

To select IP packets longer than 576 bytes sent through gateway “snup”:

gateway snup and ip[2:2] > 576

To select IP broadcast or multicast packets that were not sent via Ethernet broadcast or multicast:

ether[0] & 1 = 0 and ip[16] >= 224

To select all ICMP packets that are not echo requests/replies (i.e. not ping packets):

icmp[icmptype] != icmp-echo and icmp[icmptype] != icmp-echoreply

pcap_open_live(3), tcpdump(8)

The original authors are Van Jacobson, Craig Leres, and Steven McCanne, all of the Lawrence Berkeley National Laboratory, University of California, Berkeley, CA.

September 7, 2021 OpenBSD-7.0