|MAN.CONF(5)||File Formats Manual||MAN.CONF(5)|
configuration file for man
This file is an ASCII text file. Leading whitespace on lines, lines starting with ‘#’, and blank lines are ignored. Words are separated by whitespace. The first word on each line is the name of a configuration directive.
The following directives are supported:
Each path is a tree containing subdirectories whose names
consist of the strings ‘man’ and/or ‘cat’
followed by the names of sections, usually single digits. The former are
supposed to contain unformatted manual pages in
man(7) format; file names
should end with the name of the section preceded by a dot. The latter
should contain preformatted manual pages; file names should end with
with makewhatis(8) in
each directory configured with
recommended and necessary for
apropos(1) to work, and
also for man(1) on operating
systems like OpenBSD that install each manual
page with only one file name in the file system, even if it documents
multiple utilities or functions.
-Ocommand line options of the same names. For details, see the mandoc(1) manual.
||print only body|
||path to header files|
||path for Xr links|
||print table of contents|
The following configuration file reproduces the defaults:
installing it is equivalent to not having a
file at all.
manpath /usr/share/man manpath /usr/X11R6/man manpath /usr/local/man
A relatively complicated
format first appeared in 4.3BSD-Reno. For
OpenBSD 5.8, it was redesigned from scratch, aiming
Ingo Schwarze <email@example.com>
|February 10, 2020||OpenBSD-6.8|