|EDITRC(5)||File Formats Manual||EDITRC(5)|
configuration file for editline library
editrc file defines various settings
to be used by the
The format of each line is:
[prog:]command [arg ...]
prog may also be a regex(3) style regular expression, in which case command will be executed for any program that matches the regular expression.
If prog is absent, command is executed for all programs.
editline library has some builtin
commands, which affect the way that the line editing and history functions
operate. These are based on similar named builtins present in the tcsh
The following builtin commands are available:
-aeklrsv] [key [command]]
The options are as follows:
The editline(7) manual documents all editor commands and contains more information about macros and the input queue.
key and command can contain control characters of the form ‘^character’ (e.g. ‘^A’), and the following backslashed escape sequences:
‘\’ nullifies the special meaning of the following character, if it has any, notably ‘\’ and ‘^’.
-sv] arg ...
-s returns an empty string for
non-existent capabilities, rather than causing an error.
-v causes messages to be verbose.
editlinefunctionality in a program.
historylist | size
nentries. The unique command controls if history should keep duplicate entries. If
nis non zero, only keep unique history entries. If
nis zero, then keep all entries (the default).
-adqx] [+mode] [-mode] [mode] [char=c]
editrcwon't allow the user to change.
settyto act on the ‘edit’, ‘quote’ or ‘execute’ set of tty modes respectively; defaulting to
Without other arguments,
the modes in the chosen set which are fixed on (‘+mode’)
or off (‘-mode’).
-a lists all tty
modes in the chosen set regardless of the setting. With
+mode, -mode or
mode, fixes mode on or off
or removes control of mode in the chosen set.
Setty can also be used to set tty
characters to particular values using char=value.
If value is empty then the character is set to
editline library was written by
Christos Zoulas, and this manual was written by
Luke Mewburn, with some sections inspired by
|April 23, 2020||OpenBSD-6.8|