|WPI(4)||Device Drivers Manual||WPI(4)|
wpi — Intel
PRO/Wireless 3945ABG IEEE 802.11a/b/g wireless network device
wpi* at pci?
wpi driver provides support for Intel
PRO/Wireless 3945ABG Mini PCI Express network adapters.
These are the modes the
wpi driver can
wpi driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA1 and WPA2).
WPA2 is the current encryption standard for wireless networks. It is
strongly recommended that neither WEP nor WPA1 are used as the sole
mechanism to secure wireless communication, due to serious weaknesses. WPA1
is disabled by default and may be enabled using the option
wpa1,wpa2". For standard WPA networks which use
pre-shared keys (PSK), keys are configured using the
wpakey" option. WPA-Enterprise networks
require use of the wpa_supplicant package. The
driver offloads both encryption and decryption of unicast data frames to the
hardware for the CCMP cipher.
In BSS mode, the driver supports powersave mode, which can be enabled via ifconfig(8).
The driver needs at least version 3.1 of the following firmware file, which is loaded when an interface is brought up:
This firmware file is not free because Intel refuses to grant distribution rights without contractual obligations. As a result, even though OpenBSD includes the driver, the firmware file cannot be included and users have to download this file on their own.
A prepackaged version of the firmware can be installed using fw_update(1).
The following example scans for available networks:
# ifconfig wpi0 scan
The following hostname.if(5) example configures wpi0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
wpi driver first appeared in
wpi driver was written by
|November 10, 2019||OpenBSD-6.7|