|UNWIND(8)||System Manager's Manual||UNWIND(8)|
validating DNS resolver
unwind is a validating DNS resolver. It is
intended to run on client machines like workstations or laptops and only
listens on localhost.
unwind sends DNS queries to
nameservers to answer queries and switches to resolvers learned from
dhclient(8) if it detects
that DNS queries are blocked by the local network. It periodically probes if
DNS is no longer blocked and switches back to querying nameservers
unwind enabled at boot time, use
“rcctl enable unwind”, which sets
supersede domain-name-servers 127.0.0.1;
to /etc/dhclient.conf configures a machine
using DHCP to use
unwind can be controlled with
The options are as follows:
unwindwill run in the foreground and log to stderr.
-voptions increase the verbosity.
P. Mockapetris, DOMAIN NAMES - CONCEPTS AND FACILITIES, RFC 1034, November 1987.
P. Mockapetris, DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION, RFC 1035, November 1987.
unwind program first appeared in
unwind program was written by
|April 21, 2020||OpenBSD-6.7|