|TRPT(8)||System Manager's Manual||TRPT(8)|
transliterate protocol trace
trpt interrogates the buffer of TCP trace
records created when a socket is marked for “debugging” (see
prints a readable description of these records. When no options are
trpt prints all the trace records found in
the system grouped according to TCP connection protocol control block
The options are as follows:
The recommended use of
trpt is as follows.
Isolate the problem and enable debugging on the socket(s) involved in the
connection. Find the address of the protocol control blocks associated with
the sockets using the
-A option to
netstat(1). Then run
trpt with the
supplying the associated protocol control block addresses. The
-f option can be used to follow the trace log once
the trace is located. If there are many sockets using the debugging option,
-j option may be useful in checking to see if
any trace records are present for the socket in question.
trpt requires the ability to open
/dev/kmem which may be restricted based upon the
value of the kern.allowkmem
trpt command appeared in
Should also print the data for each input or output, but this is not saved in the trace record.
The output format is inscrutable and should be described here.
|September 25, 2016||OpenBSD-6.7|