|PCIBIOS(4)||Device Drivers Manual (i386)||PCIBIOS(4)|
introduction to PCI BIOS support
pcibios0 at bios0 flags 0x0000
OpenBSD provides support for setting up PCI controllers, bridges, and devices using information extracted from the BIOS.
Ideally, the boot firmware of a machine (a.k.a. BIOS) should set up all PCI devices; assigning them I/O and memory addresses and interrupts. Alas, this does not always happen, so there is some PC specific code that can do the initialization when OpenBSD boots.
Flags is a bit mask each bit of which specifies a fixup procedure to omit. The following list specifies these procedures and gives flags bit values to disable them in case they cause problems.
Some BIOS implementations don't allocate I/O space and memory space for all PCI devices. Especially, a BIOS which has "PnP OS mode" enabled shows this behavior. Since necessary space isn't allocated, those devices will not work without special handling.
Without this flag force allocation of I/O space and memory space instead of relying upon the BIOS to do so.
If necessary space is already correctly assigned to the devices, this option leaves the space as is.
Although many BIOS implementations leave CardBus bridges' space unallocated, the CardBus bridge device driver doesn't require this option, since the driver allocates necessary space by itself.
Each PCI bus and CardBus should have a unique bus number. But some BIOS implementations don't assign a bus number for subordinate PCI buses. And many BIOS implementations don't assign a bus number for CardBuses.
A typical symptom of this is the following boot message:
Without this flag force assignment of bus numbers for all subordinate PCI buses and CardBuses.
Since this procedure renumbers all PCI buses and CardBuses, all bus numbers of subordinate buses become different when this option is enabled.
Some BIOS implementations don't assign an interrupt for some devices.
This procedure assigns an interrupt for such devices instead of relying upon the BIOS to do so.
If the BIOS has already assigned an interrupt to a device, this procedure leaves the interrupt as is.
Without this flag, if a PCI interrupt router is not known, interrupt configuration will not be modified.
pcibiostasks. Included in these diagnostics are: PCI device address fixup tables, interrupt fixup reports, and other diagnostic and non-fatal messages.
pcibios code appeared in
NetBSD 1.5. OpenBSD support
was added in OpenBSD 2.8. In contrast to
pcibios in OpenBSD is a real
device, where options control is done through the
flags which are modifiable through the
interface. For OpenBSD 2.9 the PCI interrupt routing
establishment sequence was redone to only fixup and route interrupts when
attaching interrupts for a particular PCI device.
The PCIBIOS Address Fixup option may conflict with the PCI CardBus driver's own address fixup.
|July 1, 2008||OpenBSD-6.7|