|GSC(4)||Device Drivers Manual (hppa)||GSC(4)|
gsc — introduction
to HP 9000/700 GSC bus support
gsc* at lasi?
gsc* at asp?
gsc* at wax?
The General System Connect (GSC) bus is the core I/O bus for all HP 9000/700 workstations. All I/O subsystems connect to this bus. The devices can be either on separate chips, expansion cards or on an integrated megacell, like the LASI MBA.
The GSC bus is a 32-bit wide, address and data multiplexed bus. In its "standard" implementation it has a maximum throughput of 160MB/s, the "2x" implementation reaches up to 250MB/s. Some HPPA CPUs directly attach to this bus, namely the PA7100LC and PA7300LC.
As for the expansion cards, there are different form-factors, depending on bus-speed (standard or 2x) and specific models. The standard formfactor is the "EISA form-factor"; cards that look like typical EISA cards with a different connector (100-pin female EBBL). The Series 712 have their own special type of GSC expansion cards, called the "GIO form-factor", which is quite small and mostly has only one VLSI chip on it (in most cases LASI/WAX). Newer systems sometimes feature the "HSC formfactor", which is a 1U-VME card-like expansion card with a 100-pin male pin+socket connector. Mixing cards with different speeds is supported but downgrades the performance of the whole I/O-subsystem.
OpenBSD provides support for the following devices:
gsc driver appeared in
|December 21, 2011||OpenBSD-6.7|