|BWFM(4)||Device Drivers Manual||BWFM(4)|
bwfm — Broadcom
and Cypress IEEE 802.11a/ac/b/g/n wireless network device
bwfm* at pci?
bwfm* at sdmmc?
bwfm* at usb?
bwfm driver provides support for
Broadcom and Cypress FullMAC wireless network adapters.
The following table summarizes supported chipsets and their
capabilites, as well as the bus attachments recognized by the
These are the modes the
bwfm driver can
bwfm driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA1 and WPA2).
WPA2 is the current encryption standard for wireless networks. It is
strongly recommended that neither WEP nor WPA1 are used as the sole
mechanism to secure wireless communication, due to serious weaknesses. WPA1
is disabled by default and may be enabled using the option
wpa1,wpa2". For standard WPA networks which use
pre-shared keys (PSK), keys are configured using the
wpakey" option. WPA-Enterprise networks
require use of the wpa_supplicant package. The
driver relies on the software 802.11 stack for the WPA handshake. Both
encryption and decryption of data frames are handled by the firmware.
The firmware automatically selects the transmit speed and the channel depending on the received signal strength.
The driver needs a firmware file which is loaded when the driver attaches. A prepackaged version of the firmware can be installed using fw_update(1).
The following example scans for available networks:
# ifconfig bwfm0 scan
The following hostname.if(5) example configures bwfm0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
The following hostname.if(5) example creates a host-based access point on boot:
mediaopt hostap nwid mynwid wpakey mywpakey inet 192.168.1.1 255.255.255.0
bwfm driver first appeared in
bwfm driver was written by
The firmware is outdated and contains known vulnerabilities.
This driver does not support powersave mode.
|April 20, 2020||OpenBSD-6.7|