|AHCI(4)||Device Drivers Manual||AHCI(4)|
ahci — Advanced
Host Controller Interface for Serial ATA
ahci* at acpi?
ahci* at fdt?
ahci* at pci?
ahci* at jmb?
ahci driver provides support for
Serial ATA controllers conforming to the Advanced Host Controller Interface
Several AHCI capable controllers also provide a compatibility mode that causes them to appear as a traditional ATA controller supported by pciide(4).
ahci controllers are actual ATA
controllers, the driver emulates SCSI via a translation layer.
Setting the lowest bit (0x1) of the driver flags forces
ahci to negotiate SATA 1 (1.5 Gb/s) transfer speeds
only. It may be useful where higher speeds are unstable.
ahci driver first appeared in
|July 2, 2018||OpenBSD-6.7|