|RESTORE(8)||System Manager's Manual||RESTORE(8)|
— restore files or file systems from backups made
restore command performs the inverse
function of dump(8). A full
backup of a file system may be restored and subsequent incremental backups
layered on top of it. Single files and directory subtrees may be restored
from full or partial backups. Other arguments to the command are file or
directory names specifying the files that are to be restored. Unless the
-h flag is specified (see below), the appearance of
a directory name refers to the files and (recursively) subdirectories of
restore works across networks, replacing
the functionality of the old
restore may still be invoked as
rrestore). See the
for more on reading backups from remote hosts.
Exactly one of the following flags is required:
restoreprovides a shell like interface that allows the user to move around the directory tree selecting files to be extracted. The available commands are given below; for those commands that require an argument, the default is the current directory.
-hflag is specified on the command line). Files that are on the extraction list are prepended with a “*” when they are listed by
-hflag is specified on the command line). The most expedient way to extract most of the files from a directory is to add the directory to the extraction list and then delete those files that are not needed.
restorewill ask which volume the user wishes to mount. The fastest way to extract a few files is to start with the last volume and work towards the first volume.
-vflag is toggled. When set, the verbose flag causes the
lscommand to list the inode numbers of all entries. It also causes
restoreto print out information about each file as it is extracted.
restorerequests a particular tape of a multi-volume set on which to restart a full restore (see the
-rflag below). This is useful if the restore has been interrupted.
-rflag may be used to restore any necessary incremental backups on top of the level 0. The
-rflag precludes an interactive file extraction and can be detrimental to one's health (not to mention the disk) if not used carefully. An example of correct usage:
# newfs /dev/rsd0g # mount /dev/sd0g /mnt # cd /mnt # restore rf /dev/rst0
restore leaves a file
restoresymtable in the root directory to pass
information between incremental restore passes. This file should be
removed when the last incremental has been restored.
-hflag has been specified. Note that the
-tflag replaces the function of the old dumpdir program.
-hflag is not specified, the directory is recursively extracted. The owner, modification time, and mode are restored (if possible). If no file argument is given, the root directory is extracted, which results in the entire content of the backup being extracted, unless the
-hflag has been specified.
The following additional options may be specified:
-boption is not specified,
restoretries to determine the block size dynamically.
restorewill try to determine dynamically whether the dump was made from an old (pre-4.4) or new format file system. The
-cflag disables this check, and only allows reading a dump in the old format.
-” (the standard input). If the name of the file is of the form “host:file” or “user@host:file”,
restorereads from the named file on the remote host using rmt(8).
restoredoes its work silently. The
-v(verbose) flag causes it to type the name of each file it treats preceded by its file type.
If the following environment variable exists it will be utilized
Complains if it gets a read error. If
has been specified, or the user responds “y”,
restore will attempt to continue the restore.
If a backup was made using more than one tape volume,
restore will notify the user when it is time to
mount the next volume. If the
-i flag has been specified,
restore will also ask which volume the user wishes
to mount. The fastest way to extract a few files is to start with the last
volume, and work towards the first volume.
There are numerous consistency checks that can be listed by
restore. Most checks are self-explanatory or can
“never happen”. Common errors are given below.
restoremay have to resynchronize itself. This message lists the number of blocks that were skipped over.
restore command appeared in
The 4.3BSD option syntax is implemented for backward compatibility but is not documented here.
restore can get confused when doing
incremental restores from dumps that were made on active file systems.
A level 0 dump must be done after a full restore. Because
restore runs in user mode, it has no control over
inode allocation; thus a full dump must be done to get a new set of
directories reflecting the new inode numbering, even though the content of
the files is unchanged.
The temporary files /tmp/rstdir* and
/tmp/rstmode* are generated with a unique name based
on the date of the dump and the process ID (see
mktemp(3)), except when
-R is used. Because
-R allows you to restart a
-r operation that may have been interrupted, the
temporary files should be the same across different processes. In all other
cases, the files are unique because it is possible to have two different
dumps started at the same time, and separate operations shouldn't conflict
with each other.
|November 21, 2015||OpenBSD-6.5|