|MALO(4)||Device Drivers Manual||MALO(4)|
malo — Marvell
Libertas IEEE 802.11b/g wireless network device
malo* at cardbus?
malo* at pci?
malo* at pcmcia?
malo driver provides support for
Marvell Libertas 88W8335/88W8310/88W8385 based PCI/CardBus/PCMCIA network
adapters. The second generation 88W8335/88W8310 chipsets support
These are the modes the
malo driver can
malo driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and
WPA2-PSK). WPA is the current encryption standard for wireless networks. It
is strongly recommended that WEP not be used as the sole mechanism to secure
wireless communication, due to serious weaknesses in it. The
malo driver relies on the software 802.11 stack for
both encryption and decryption of data frames.
The driver needs a set of firmware files which are loaded when an interface is brought up:
These firmware files are not free because Marvell refuses to grant distribution rights. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own.
A prepackaged version of the firmware can be installed using fw_update(1).
The following cards are among those supported by the
|I-O DATA WN-G54/CF||88W8385||PCMCIA||b/g|
The following example scans for available networks:
# ifconfig malo0 scan
The following hostname.if(5) example configures malo0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
malo driver first appeared in
malo driver was written by
Claudio Jeker and Marcus
WPA encryption is not supported for PCMCIA devices.
This driver does not support powersave mode.
|March 29, 2019||OpenBSD-6.5|