|FBTAB(5)||File Formats Manual||FBTAB(5)|
fbtab — change
device protection upon login
fbtab file contains lines which
specify how the permissions and ownership of various system files should be
changed based on the user's login device name.
Comments start with a ‘
and extend to the end of the line. Blank lines or lines with only a comment
All other lines consist of three fields delimited by whitespace.
:’) delimited list of devices (e.g., “/dev/console:/dev/fd0a”). All device names are absolute paths. A path that ends in “/*” refers to all directory entries except “.” and “..”.
fbtab file is used by
chown(2) the specified files
to the user who has performed a login. Additionally,
chmod(2) is used to set the
devices to the specified permission. When a user logs out,
init(8) is responsible for
performing the inverse operation, which results in the files once again
belonging to root.
Guido van Rooij
|September 8, 2014||OpenBSD-6.5|