|MAKEFILE.YP(8)||System Manager's Manual||MAKEFILE.YP(8)|
generate and distribute YP maps
cd /var/yp; make
Makefile.yp utility generates or
updates the YP maps to be served by
Each YP domain to be served must have its own subdirectory below /var/yp. Use ypinit(8) to set up such subdirectories. In particular, ypinit(8) will copy /var/yp/Makefile.yp into each new domain subdirectory. For common configuration changes affecting all future domains, edit /var/yp/Makefile.yp before running ypinit(8). For configuration changes affecting only one individual domain, edit the Makefile in the respective domain subdirectory after running ypinit(8). Do not edit /var/yp/Makefile.yp.dist.
By default, input data for generating YP maps is collected from
the /etc directory. Edit the
DIR variable to choose a different source
To regenerate all maps for all domains, run make(1) in /var/yp. To regenerate all maps for one single domain, run make(1) in the respective domain subdirectory. The makedbm(8) utility will be used to create the maps in Berkeley DB format, and they will be stored inside the appropriate domain subdirectory.
Whenever a YP map has been updated, it is automatically
distributed to all slave servers in the respective domain using the
yppush(8) utility. To disable
automatic distribution, set the
NOPUSH variable to
an arbitrary, non-empty, value.
Makefile.yp provides the
following make(1) targets:
The master.passwd.* maps always contain complete records in master.passwd(5) format, including the encrypted passwords.
The passwd.* maps follow the reduced
passwd(5) format having
the class, change, and expire fields removed but by default the
encrypted passwords are included too. If the
UNSECURE variable is changed to be empty, the
encrypted passwords are replaced by asterisks
*’). This “secure”
mode is compatible with OpenBSD and
MAXUID variables restrict the range of user IDs
included into the four passwd maps. By default, system users are not
MAXGID variables restrict the range of group IDs
included into both group maps. By default, system groups are not
ypserv(8) to ask DNS for
unknown hosts, set the
USEDNS variable to
-biand the mkalias(8) utility.
In order to keep additional custom YP maps up to date, the Makefile should be extended to support additional targets.
NOPUSH is set and individual maps are
regenerated (as opposed to
all), the hangup signal
to ypserv(8) must be sent
manually, or the new maps won't be used.
NOPUSH is unset, maps are pushed to
the master server on the local host too, slowing down
|April 26, 2018||OpenBSD-6.5|