|WSMUX(4)||Device Drivers Manual||WSMUX(4)|
wsmux — console
keyboard/mouse multiplexor for wscons
wskbd* at ... mux N
wsmouse* at ... mux N
pseudo-device wsmux [count]
wsmux is a pseudo-device driver that
allows several wscons(4)
input devices to have their events multiplexed into one stream.
The typical usage for this device is to have two multiplexors, one for mouse events and one for keyboard events. All wsmouse(4) devices should direct their events to the mouse mux (normally 0) and all keyboard devices, except the console, should direct their events to the keyboard mux (normally 1). A device will send its events to the mux indicated by the mux locator. If none is given the device will not use a multiplexor. The keyboard multiplexor should be connected to the display, using the wsconscfg(8) command. It will then receive all keystrokes from all keyboards and, furthermore, keyboards can be dynamically attached and detached without further user interaction. In a similar way, the window system will open the mouse multiplexor and receive all mouse events; mice can also be dynamically attached and detached.
It is also possible to inject events into a multiplexor from a user program. This is used by the wsmoused(8) daemon to take data from a mouse connected to a serial port and make it appear on the standard mouse mux.
|June 26, 2008||OpenBSD-6.2|