OpenBSD manual page server

Manual Page Search Parameters
BOOT(8) System Manager's Manual (socppc) BOOT(8)

boot, boot.confsocppc-specific bootstrap

The main purpose of this program is to load the system kernel.

This program is loaded by the firmware and provides a convenient way to load the kernel. This program acts as an enhanced boot monitor for socppc systems, providing a common interface for the kernel to start from.

Basic operations include:

The sequence of its operation is as follows: initialization, parsing the configuration file, then an interactive command line. While at the command line you have 5 seconds to type any commands, if needed. If time expires, the kernel will be loaded according to the current variable settings (see the set command). Each time a kernel load fails, the timeout is increased by one second. The sequence of boot operations is as follows:

  1. If the file /etc/boot.conf exists on the filesystem in slice ‘a’ on the first disk drive (wd0), open and parse it. Lines beginning with the ‘#’ character, as well as whitespace at the beginning of lines, are ignored. The file may contain any commands boot accepts at the interactive prompt. Though default settings usually suffice, they can be changed here.
  2. The header line

    >> OpenBSD/socppc BOOT [x.xx]

    is displayed to the active console, where x.xx is the version number of the boot program, followed by the

    boot>

    prompt, which means you are in interactive mode and may enter commands. If you do not, boot will proceed to load the kernel with the current parameters after the timeout period has expired.

By default, boot attempts to load the kernel executable /bsd. If it fails to find the kernel and no alternative kernel image has been specified, the system will be unable to boot.

The following commands are accepted at the boot prompt:

boot [[device:]image] [-acds]
Boots the specified kernel image with any options given. If device or image are omitted, values from boot variables will be used.

The only bootable devices, at the moment, are IDE devices connected to the internal controller; they are detected as ‘wd’ devices. Therefore, to boot kernel /bsd from slice ‘a’ on the first hard drive, specify “boot wd0a:/bsd”.

Causes the kernel to ask for the root device to use.
Causes the kernel to go into boot_config(8) before performing autoconf(4) procedures.
Causes the kernel to drop into ddb(4) at the earliest convenient point.
Causes the kernel to boot single-user.
echo [args]
Displays args on the console device.
help
Prints a list of available commands.
ls [directory]
Prints contents of the specified directory in long format including: attributes and file type, owner, group, size, filename.
reboot
Reboots the machine by initiating a warm boot procedure.
set [varname [value]]
If invoked without arguments, prints a list of variables and their values. If only varname is specified, displays contents of that variable. If varname and value are both specified, sets that variable to the given value. Variables include:

addr
Address at which to load the kernel.
debug
Debug flag if boot was compiled with DEBUG defined.
device
Boot device name (e.g., wd0a, wd1a).
howto
Options to pass to the loaded kernel.
image
File name containing the kernel image.
timeout
Number of seconds boot will wait for human intervention before booting the default kernel image.
time
Displays system time and date.

/usr/mdec/boot
system bootstrap
/etc/boot.conf
system bootstrap's startup file
/bsd
kernel image
/bsd.rd
kernel image for installation/recovery

Boot the default kernel:

boot> boot

Remove the 5 second pause at boot-time permanently, causing boot to load the kernel immediately without prompting:

# echo "boot" > /etc/boot.conf

Boot the kernel named /bsd from the second hard disk in “User Kernel Configuration” mode (see boot_config(8)). This mechanism allows for the explicit enabling and disabling of devices during the current boot sequence, as well as the modification of device parameters. Once booted, such changes can be made permanent by using config(8)'s -e option.

boot> boot wd1a:/bsd -c

gzip(1), autoconf(4), ddb(4), boot_config(8), fdisk(8), reboot(8)

This program was written by Michael Shalayeff for OpenBSD 2.1 on the i386 platform, and was later ported to the socppc platform for OpenBSD 4.4.

July 6, 2017 OpenBSD-6.2