OpenBSD manual page server

Manual Page Search Parameters
APM(4) Device Drivers Manual (macppc) APM(4)

apmadvanced power management device interface

apm0 at adb?

The apm driver provides an interface which simulates the Advanced Power Management (APM) BIOS functions. The BIOS functions are translated into the appropriate PowerManager requests. Currently only battery level, AC connection, and charging status is available from the apm device. Suspend/resume and other power events are NOT YET SUPPORTED.

Configuration options:

Enable various driver status messages.
Enable debugging messages.
Enable other debugging messages.

The apm driver implements the following ioctl(2) calls. They are defined in <machine/apmvar.h>.

. .
(no parameters) Request “standby” mode.
(no parameters) Request “suspend” mode.
(struct apm_power_info) Request the current power state. The argument structure is as follows:
struct apm_power_info {
	u_char battery_state;
	u_char ac_state;
	u_char battery_life;
	u_char spare1;
	u_int minutes_left;
	u_int spare2[6];
};

The following values are defined for battery_state:

Battery has a high state of charge.
Battery has a low state of charge.
Battery has a critical state of charge.
Battery is not high, low, or critical and is currently charging.
Cannot read the current battery state.
No battery installed.

The following values are defined for ac_state:

External power not detected.
External power detected.
Backup power in use.
External power state unknown.

The battery_life value contains the estimated percentage of battery life available. 100% indicates a full charge.

If the battery is charging, i.e. when battery_state is equal to APM_BATT_CHARGING, the battery_life value contains the estimated number of minutes until the battery will be fully charged. Otherwise, the minutes_left value contains the estimated number of minutes of battery life remaining.

(struct apm_event_info) The APM driver stores up to APM_NEVENTS events. This was defined as 16 at the time this documentation was written. If the event list is full when a new event is detected the new event is lost. APM_IOC_NEXTEVENT ioctl returns the next event on the list or EAGAIN if the event list is empty. The format of the returned event is:
struct apm_event_info {
	u_int type;
	u_int index;
	u_int spare[8];
};
where index is a sequential count of events that can be used to check if any events were lost and type is one of:

(struct apm_ctl) Allows an application to directly set the APM operating mode. The argument structure is as follows:
struct apm_ctl {
	u_int dev;
	u_int mode;
};

dev indicates the device, typically APM_DEV_ALLDEVS.

mode indicates the desired operating mode. Possible values are

(int) This ioctl(2) controls message output by the APM driver when a power change event is detected. The integer parameter is one of:
All power change events result in a message. This is the normal operating mode for the driver.
Power change event messages are suppressed.
Power change event messages are suppressed unless the estimated battery life percentage changes.

However, in no case will power status messages be displayed until the battery life goes below the percentage in the sysctl(8) state variable machdep.apmwarn. Setting machdep.apmwarn to zero disables all warnings regardless of the APM_IOC_PRN_CTL setting.

NOT YET SUPPORTED on macppc: As noted above, the operation of the APM driver can be modified using the machdep.apmwarn sysctl(8) variable. Another driver modifier is the machdep.apmhalt variable. When machdep.apmhalt is set to 1 the APM power down code is modified in a way necessary for correct operation on some systems, mainly IBM laptops. If your system does not power down when given the command halt -p try setting machdep.apmhalt to 1 using sysctl(8). The variable can be set at boot time in sysctl.conf(5).

/dev/apm
Power management data device. May only be opened read-only. May be opened by multiple concurrent users.
/dev/apmctl
Power management control device. May be opened read-write or write-only. May only be opened by one user at a time. An attempt to open the file when in use will fail, returning EBUSY.

adb(4), intro(4), sysctl.conf(5), apm(8), apmd(8), halt(8), sysctl(8)

The apm driver source code contains these copyrights:

...and has been hacked on by many others since.

Sleep modes and power events are not supported.

February 27, 2016 OpenBSD-6.2