OpenBSD manual page server

Manual Page Search Parameters

VWAITFORIO(9) Kernel Developer's Manual VWAITFORIO(9)

vwaitforiowait for all outstanding asynchronous writes

#include <sys/types.h>
#include <sys/vnode.h>

int
vwaitforio(struct vnode *vp, int slpflag, char *wmesg, int slptimeo);

The () call sleeps until all asynchronous writes associated with the vnode vp finish. This is used by functions that need to make sure that the writes they initiated have completed.

The () call sleeps at priority PRIBIO + 1 . The slpflag, wmesg, and slptimeo arguments indicate flags to be passed to tsleep(9).

This function must be called at splbio(9).

It may be important to ensure that no other process submits asynchronous writes while a process is waiting for I/O on this vnode. Otherwise, () may never return.

The vwaitforio() function returns 0 on success. See tsleep(9) for possible error returns.

tsleep(9), vnode(9)

September 14, 2015 OpenBSD-6.1