OpenBSD manual page server

Manual Page Search Parameters

VREF(9) Kernel Developer's Manual VREF(9)

vrefincrement the use count for a vnode

#include <sys/param.h>
#include <sys/vnode.h>

void
vref(struct vnode *vp);

Increment the v_usecount field of the vnode specified by vp.

Each vnode maintains a reference count of how many parts of the system are using the vnode. This allows the system to detect when a vnode is no longer being used and can be safely recycled for a different file.

Any code in the system which uses a vnode (e.g. during the operation of some algorithm or to store in a data structure) should call ().

vget(9), vnode(9), vput(9), vrele(9)

This man page was originally written by Doug Rabson for FreeBSD.

June 4, 2013 OpenBSD-6.1