OpenBSD manual page server

Manual Page Search Parameters

VFINDDEV(9) Kernel Developer's Manual VFINDDEV(9)

vfinddevlookup a vnode by device number

#include <sys/param.h>
#include <sys/vnode.h>

int
vfinddev(dev_t dev, enum vtype type, struct vnode **vpp);

The () function returns a pointer to the vnode of the device represented by the device number dev and of type type in vpp.

vfinddev() will return 1 if a corresponding vnode was found, 0 otherwise.

vnode(9)

This man page was originally written for OpenBSD.

June 4, 2013 OpenBSD-6.1