|SES(4)||Device Drivers Manual||SES(4)|
ses* at scsibus?
sesdriver provides support for monitoring the various environmental sensors present in SCSI enclosures using the SCSI Enclosure Services command set. The hardware monitoring is accessed via the hw.sensors sysctl(8) variable.
SCSI devices have a fairly high level interface to the system and talk to it via a SCSI host adapter (e.g. ahc(4)). A SCSI adapter must also be separately configured into the system before a SCSI enclosure can be configured.
When the SCSI adapter is probed during boot, the SCSI bus is
scanned for devices. Any SCSI-2 devices of type “Enclosure
service” or SCSI-3 devices of type “Processor” will be
attached to the
SES compliant devices can provide an arbitrary set of sensors which may include the following types:
Sensor data is updated every 10 seconds.
An enclosure may provide environmental information using an alternative command set to the SCSI Enclosure Services used by this driver. Enclosures using the SCSI Accessed Fault-Tolerant Enclosure command set may be monitored by the safte(4) driver.
sesdriver first appeared in OpenBSD 3.8.
sesdriver was written by David Gwynne <email@example.com>.
|July 16, 2013||OpenBSD-6.1|