|MOUNT_NTFS(8)||System Manager's Manual||MOUNT_NTFS(8)|
mount_ntfscommand attaches the NTFS filesystem residing on the device special to the global filesystem namespace at the location indicated by node. This command is invoked by mount(8) when using the syntax
mount[options] -t ntfs special node
The special device is either a disklabel(8) UID (DUID) or an entry in /dev. If it is a DUID, it will be automatically mapped to the appropriate entry in /dev. In either case the partition must be present in the disklabel loaded from the device. The partition name is the last letter in the entry name. For example, /dev/sd0a and 3eb7f9da875cb9ee.a both refer to the ‘a’ partition.
The supported NTFS versions include both NTFS4, as used by Microsoft Windows NT 4.0, and NTFS5, as used by Microsoft Windows 2000 and XP. Only read-only operation is permitted, which is automatically enforced.
The options are as follows:
-oflag followed by a comma separated string of options. See the mount(8) man page for possible options and their meanings.
‘ATTRTYPE’ is one of identifier listed in $AttrDef file of volume. Default is $DATA. ‘ATTRNAME’ is an attribute name. Default is none.
To get volume name (in Unicode):
# cat /mnt/\$Volume:\$VOLUME_NAME
To read directory raw data:
# cat /mnt/foodir:\$INDEX_ROOT:\$I30
mount_ntfs, and this manual were originally written by Semen Ustimenko <semenu@FreeBSD.org>.
The OpenBSD port was done by Julien Bordet <email@example.com>.
If the NTFS partition is marked as
dynamic’ under Microsoft Windows XP,
it won't be possible to access it under OpenBSD
|January 21, 2014||OpenBSD-6.1|