|GIF(4)||Device Drivers Manual||GIF(4)|
gifinterface is a generic tunnelling pseudo-device for IPv4 and IPv6. It can tunnel IPv over IPv with behavior mainly based on RFC 4213 IPv6-over-IPv4, for a total of four possible combinations.
gif interface must be configured with
the addresses used for the outer header. This can be done by using
tunnel command (which uses the
The addresses of the inner header must be configured by using
ifconfig(8) in the normal
way. The routing table can be used to direct packets toward the
gifdevice first appeared in WIDE hydrangea IPv6 kit.
gifmay not interoperate with peers which are based on different specifications, and are picky about outer header fields. For example, you cannot usually use
gifto talk with IPsec devices that use IPsec tunnel mode.
The current code does not check if the ingress address (outer
source address) configured to
gif makes sense. Make
sure to configure an address which belongs to your node. Otherwise, your
node will not be able to receive packets from the peer, and your node will
generate packets with a spoofed source address.
If the outer protocol is IPv6, path MTU discovery for encapsulated packet may affect communication over the interface.
|June 7, 2016||OpenBSD-6.1|