|MAILER.CONF(5)||File Formats Manual||MAILER.CONF(5)|
configuration file for mailwrapper(8)
The file /etc/mailer.conf contains a
series of pairs. The first member of each pair is the name of a program
which is typically a symbolic link to
/usr/sbin/sendmail. (On a typical system,
mailq(8) would be set up this
way.) The second member of each pair is the name of the program to actually
execute when the first name is invoked. The file may also contain comments,
denoted by a ‘
#’ character in the
first column of any line.
The following is an example of how to set up
mailer.conf for the default
smtpd(8) MTA suite .
# Emulate sendmail using smtpd sendmail /usr/sbin/smtpctl send-mail /usr/sbin/smtpctl mailq /usr/sbin/smtpctl makemap /usr/sbin/smtpctl newaliases /usr/sbin/smtpctl
# Execute the "real" sendmail program, named /usr/libexec/sendmail/sendmail sendmail /usr/libexec/sendmail/sendmail send-mail /usr/libexec/sendmail/sendmail mailq /usr/libexec/sendmail/sendmail makemap /usr/libexec/sendmail/makemap newaliases /usr/libexec/sendmail/sendmail hoststat /usr/libexec/sendmail/sendmail purgestat /usr/libexec/sendmail/sendmail
Perry E. Metzger <email@example.com>
The entire reason this program exists is a crock. Instead, a command for how to submit mail should be standardized, and all the "behave differently if invoked with a different name" behavior of things like mailq(8) should go away.
|December 8, 2015||OpenBSD-6.0|