OpenBSD manual page server

Manual Page Search Parameters

TVTOHZ(9) Kernel Developer's Manual TVTOHZ(9)

tvtohz, tstohztranslate time period to timeout delay

#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>

int
tvtohz(const struct timeval *tv);

int
tstohz(const struct timespec *ts);

The () and () functions compute the number of hz in the specified amount of time. They are mainly used to translate a timeval or timespec, respectively, into a suitable argument for timeout(9).

These functions are implemented in the file sys/kern/kern_clock.c.

hz(9), timeout(9)

June 11, 2015 OpenBSD-5.9