OpenBSD manual page server

Manual Page Search Parameters

HZ(9) Kernel Developer's Manual HZ(9)

hz, tick, tickadj, stathz, profhzsystem time model

extern int hz;
extern int tick;
extern int tickadj;
extern int stathz;
extern int profhz;

The system is driven by hardclock(9) interrupts, which occur at hz frequency, and are used to keep track of real time.

On systems where another independent clock is available, it is set at stathz frequency, and used to gather timing statistics. Ideally, it would be better to drive stathz with a slightly randomized clock, that is still a fixed number on average, as this would prevent malicious processes from working around the scheduler. If a separate clock is not available, stathz is set to hz.

If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate profhz, which must be a multiple of stathz. This will give higher resolution profiling information.

Normally, hardclock(9) increments time by tick each time it is called. If the system clock has drifted, adjtime(2) may be used to skew this increment, but by no more than ten times tickadj.

Those systems variables are available as a struct clockinfo from sysctl(3).

adjtime(2), clock_getres(2), sysctl(3), hardclock(9), microtime(9)

May 31, 2007 OpenBSD-5.9