OpenBSD manual page server

Manual Page Search Parameters

PF(4)                     OpenBSD Programmer's Manual                    PF(4)

NAME
     pf - packet filter

SYNOPSIS
     pseudo-device pf 1

DESCRIPTION
     Packet filtering takes place in the kernel.  A pseudo-device, /dev/pf,
     allows userland processes to control the behavior of the packet filter
     through an ioctl(2) interface.  There are commands to enable and disable
     the filter, load rulesets, add and remove individual rules or retrieve
     state table entries and statistics.  The most commonly used functions are
     covered by pfctl(8).

     Manipulations like loading a ruleset that involve more than a single
     ioctl call require a so-called ticket, which prevents the occurrence of
     multiple concurrent manipulations.

     Fields of ioctl parameter structures that refer to packet data (like ad-
     dresses and ports) are generally expected in network byte-order.

FILES
     /dev/pf  packet filtering device.

IOCTL INTERFACE
     pf supports the following ioctl(2) commands:

     DIOCSTART
             Starts the packet filter.

     DIOCSTOP
             Stops the packet filter.

     DIOCSTARTALTQ
             Starts the ALTQ bandwidth control system.

     DIOCSTOPALTQ
             Stops the ALTQ bandwidth control system.

     DIOCBEGINADDRS u_int32_t
             Clears the buffer address pool and returns a ticket for subse-
             quent DIOCADDADDR, DIOCADDRULE and DIOCCHANGERULE calls.

     DIOCADDADDR struct pfioc_pooladdr

             struct pfioc_pooladdr {
                     u_int32_t               action;
                     u_int32_t               ticket;
                     u_int32_t               nr;
                     u_int32_t               r_num;
                     u_int8_t                r_action;
                     u_int8_t                r_last;
                     u_int8_t                af;
                     char                    anchor[PF_ANCHOR_NAME_SIZE];
                     char                    ruleset[PF_RULESET_NAME_SIZE];
                     struct pf_pooladdr      addr;
             };

             Adds pool address addr to the buffer address pool to be used in
             the following DIOCADDRULE or DIOCCHANGERULE call.  All other mem-
             bers of the structure are ignored.

     DIOCBEGINRULES u_int32_t
             Clears the inactive ruleset for the type of rule indicated by
             rule.action and returns a ticket for subsequent DIOCADDRULE and
             DIOCCOMMITRULES calls.

     DIOCADDRULE struct pfioc_rule

             struct pfioc_rule {
                     u_int32_t       action;
                     u_int32_t       ticket;
                     u_int32_t       pool_ticket;
                     u_int32_t       nr;
                     char            anchor[PF_ANCHOR_NAME_SIZE];
                     char            ruleset[PF_RULESET_NAME_SIZE];
                     struct pf_rule  rule;
             };

             Adds rule at the end of the inactive ruleset.  Requires ticket
             obtained through preceding DIOCBEGINRULES call, and pool_ticket
             obtained through DIOCBEGINADDRS call.  DIOCADDADDR must also be
             called if any pool addresses are required.  The optional anchor
             and ruleset names indicate the anchor and ruleset in which to ap-
             pend the rule.  nr and action are ignored.

     DIOCCOMMITRULES u_int32_t
             Switch inactive to active filter ruleset.  Requires ticket.

     DIOCBEGINALTQS u_int32_t
             Clears the inactive list of queues and returns a ticket for sub-
             sequent DIOCADDALTQ and DIOCCOMMITALTQS calls.

     DIOCADDALTQ struct pfioc_altq
             Adds

             struct pfioc_altq {
                     u_int32_t       ticket;
                     u_int32_t       nr;
                     struct pf_altq   altq;
             };

     DIOCCOMMITALTQS u_int32_t
             Switch inactive to active list of queues.  Requires ticket.

     DIOCGETRULES struct pfioc_rule
             Returns ticket for subsequent DIOCGETRULE calls and nr of rules
             in the active ruleset.

     DIOCGETRULE struct pfioc_rule
             Returns rule number nr using ticket obtained through a preceding
             DIOCGETRULES call.

     DIOCGETADDRS struct pfioc_pooladdr
             Returns ticket for subsequent DIOCGETADDR calls and nr of pool
             addresses in the rule specified with r_action, r_num, anchor and
             ruleset.

     DIOCGETADDR struct pfioc_pooladdr
             Returns pool address addr number nr from the rule specified with
             r_action, r_num, anchor and ruleset using ticket obtained through
             a preceding DIOCGETADDRS call.

     DIOCGETALTQS struct pfioc_altq
             Returns ticket for subsequent DIOCGETALTQ calls and nr of queues
             in the active list.

     DIOCGETALTQ struct pfioc_altq
             Returns altq number nr using ticket obtained through a preceding

             DIOCGETALTQS call.

     DIOCGETQSTATS struct pfioc_qstats
             Returns statistics on a queue.

             struct pfioc_qstats {
                     u_int32_t        ticket;
                     u_int32_t        nr;
                     void            *buf;
                     int              nbytes;
                     u_int8_t         scheduler;
             };

             A pointer to a buffer of statistics buf of length nbytes for the
             queue specified by nr.

     DIOCCLRSTATES
             Clears the state table.

     DIOCADDSTATE struct pfioc_state
             Adds a state entry.

     DIOCGETSTATE struct pfioc_state

             struct pfioc_state {
                     u_int32_t        nr;
                     struct pf_state  state;
             };

             Extracts the entry with the specified number from the state
             table.

     DIOCKILLSTATES struct pfioc_state_kill
             Removes matching entries from the state table.  Returns the num-
             ber of killed states in psk_af.

             struct pfioc_state_kill {
                     int                     psk_af;
                     int                     psk_proto;
                     struct pf_rule_addr     psk_src;
                     struct pf_rule_addr     psk_dst;
             };

     DIOCSETSTATUSIF struct pfioc_if

             struct pfioc_if {
                     char             ifname[IFNAMSIZ];
             };

             Specifies the interface for which statistics are accumulated.

     DIOCGETSTATUS struct pf_status

             struct pf_status {
                     u_int64_t        counters[PFRES_MAX];
                     u_int64_t        fcounters[FCNT_MAX];
                     u_int64_t        pcounters[2][2][3];
                     u_int64_t        bcounters[2][2];
                     u_int32_t        running;
                     u_int32_t        states;
                     u_int32_t        since;
                     u_int32_t        debug;
             };


             Gets the internal packet filter statistics.

     DIOCCLRSTATUS
             Clears the internal packet filter statistics.

     DIOCNATLOOK struct pfioc_natlook
             Looks up a state table entry by source and destination addresses
             and ports.

             struct pfioc_natlook {
                     struct pf_addr   saddr;
                     struct pf_addr   daddr;
                     struct pf_addr   rsaddr;
                     struct pf_addr   rdaddr;
                     u_int16_t        sport;
                     u_int16_t        dport;
                     u_int16_t        rsport;
                     u_int16_t        rdport;
                     u_int8_t         af;
                     u_int8_t         proto;
                     u_int8_t         direction;
             };

     DIOCSETDEBUG u_int32_t
             Sets the debug level.

             enum    { PF_DEBUG_NONE=0, PF_DEBUG_URGENT=1, PF_DEBUG_MISC=2 };

     DIOCGETSTATES struct pfioc_states

             struct pfioc_states {
                     int     ps_len;
                     union {
                             caddr_t psu_buf;
                             struct pf_state *psu_states;
                     } ps_u;
             #define ps_buf          ps_u.psu_buf
             #define ps_states       ps_u.psu_states
             };

     DIOCCHANGERULE struct pfioc_rule
             Adds or removes the rule in the ruleset specified by rule.action.

             enum    { PF_CHANGE_ADD_HEAD=1, PF_CHANGE_ADD_TAIL=2,
                       PF_CHANGE_ADD_BEFORE=3, PF_CHANGE_ADD_AFTER=4,
                       PF_CHANGE_REMOVE=5, PF_CHANGE_GET_TICKET=6 };

             The type of operation to be performed is indicated by action.

             ticket must be set to the value obtained with PF_CHANGE_GET_TICK-
             ET for all actions except PF_CHANGE_GET_TICKET.  pool_ticket must
             be set to the value obtained with the DIOCBEGINADDRS call for all
             actions except PF_CHANGE_REMOVE and PF_CHANGE_GET_TICKET.

             anchor and ruleset indicate which anchor and ruleset the opera-
             tion applies to.  nr indicates the rule number against which
             PF_CHANGE_ADD_BEFORE, PF_CHANGE_ADD_AFTER or PF_CHANGE_REMOVE ac-
             tions are applied.

     DIOCCHANGEADDR struct pfioc_addr
             Adds or removes a pool address addr from a rule specified with
             r_action, r_num, anchor and ruleset.

     DIOCSETTIMEOUT struct pfioc_tm

             struct pfioc_tm {
                     int              timeout;
                     int              seconds;
             };

     DIOCGETTIMEOUT struct pfioc_tm

     DIOCCLRRULECTRS
             Clear per-rule statistics.

     DIOCSETLIMIT struct pfioc_limit
             Sets hard limits on the memory pools used by the packet filter.

             struct pfioc_limit {
                     int             index;
                     unsigned        limit;
             };

     DIOCGETLIMIT struct pfioc_limit

     DIOCRCLRTABLES struct pfioc_table
             Clear all tables.  All the IOCTLs that manipulate radix tables
             use the same structure described below.  For DIOCRCLRTABLES,
             pfrio_ndel contains on exit the number of tables deleted.

             struct pfioc_table {
                     struct pfr_table         pfrio_table;
                     void                    *pfrio_buffer;
                     int                      pfrio_size;
                     int                      pfrio_size2;
                     int                      pfrio_nadd;
                     int                      pfrio_ndel;
                     int                      pfrio_nchange;
                     int                      pfrio_flags;
                     int                      pfrio_ticket;
             };
             #define pfrio_exists    pfrio_nadd
             #define pfrio_nzero     pfrio_nadd
             #define pfrio_nmatch    pfrio_nadd
             #define pfrio_naddr     pfrio_size2
             #define pfrio_setflag   pfrio_size2
             #define pfrio_clrflag   pfrio_nadd

     DIOCRADDTABLES struct pfioc_table
             Creates one or more tables.  On entry, pfrio_buffer[pfrio_size]
             contains a table of pfr_table structures.  On exit, pfrio_nadd
             contains the number of tables effectively created.

             struct pfr_table {
                     char                     pfrt_name[PF_TABLE_NAME_SIZE];
                     u_int32_t                pfrt_flags;
             };

     DIOCRDELTABLES struct pfioc_table
             Deletes one or more tables.  On entry, pfrio_buffer[pfrio_size]
             contains a table of pfr_table structures.  On exit, pfrio_nadd
             contains the number of tables effectively deleted.

     DIOCRGETTABLES struct pfioc_table
             Get the list of all tables.  On entry, pfrio_buffer[pfrio_size]
             contains a valid writeable buffer for pfr_table structures.  On
             exit, pfrio_size contains the number of tables written into the
             buffer.  If the buffer is too small, the kernel does not store
             anything but just returns the required buffer size, without er-
             ror.

     DIOCRGETTSTATS struct pfioc_table
             Like DIOCRGETTABLES, but returns an array of pfr_tstats
             structures.

             struct pfr_tstats {
                     struct pfr_table pfrts_t;
                     u_int64_t        pfrts_packets
                                          [PFR_DIR_MAX][PFR_OP_TABLE_MAX];
                     u_int64_t        pfrts_bytes
                                          [PFR_DIR_MAX][PFR_OP_TABLE_MAX];
                     u_int64_t        pfrts_match;
                     u_int64_t        pfrts_nomatch;
                     long             pfrts_tzero;
                     int              pfrts_cnt;
                     int              pfrts_refcnt;
             };
             #define pfrts_name      pfrts_t.pfrt_name
             #define pfrts_flags     pfrts_t.pfrt_flags

     DIOCRCLRTSTATS struct pfioc_table
             Clears the statistics of one or more tables.  On entry,
             pfrio_buffer[pfrio_size] contains a table of pfr_table struc-
             tures.  On exit, pfrio_nzero contains the number of tables effec-
             tively cleared.

     DIOCRCLRADDRS struct pfioc_table
             Clear all addresses in a table.  On entry, pfrio_table contains
             the table to clear.  On exit, pfrio_ndel contains the number of
             addresses removed.

     DIOCRADDADDRS struct pfioc_table
             Add one or more addresses to a table.  On entry, pfrio_table con-
             tains the table id and pfrio_buffer[pfrio_size] contains the list
             of pfr_addr structures to add.  On exit, pfrio_nadd contains the
             number of addresses effectively added.

             struct pfr_addr {
                     union {
                             struct in_addr   _pfra_ip4addr;
                             struct in6_addr  _pfra_ip6addr;
                     }                pfra_u;
                     u_int8_t         pfra_af;
                     u_int8_t         pfra_net;
                     u_int8_t         pfra_not;
                     u_int8_t         pfra_fback;
             };
             #define pfra_ip4addr    pfra_u._pfra_ip4addr
             #define pfra_ip6addr    pfra_u._pfra_ip6addr

     DIOCRDELADDRS struct pfioc_table
             Delete one or more addresses from a table.  On entry, pfrio_table
             contains the table id and pfrio_buffer[pfrio_size] contains the
             list of pfr_addr structures to delete.  On exit, pfrio_ndel con-
             tains the number of addresses effectively deleted.

     DIOCRSETADDRS struct pfioc_table
             Replace the content of a table by a new address list.  This is
             the most complicated command, which uses all the structure mem-
             bers.  On entry, pfrio_table contains the table id and
             pfrio_buffer[pfrio_size] contains the new list of pfr_addr struc-
             tures.  In addition to that, if size2 is nonzero,
             pfrio_buffer[pfrio_size..pfrio_size2] must be a writeable buffer,
             into which the kernel can copy the addresses that have been
             deleted during the replace operation.  On exit, pfrio_ndel,
             pfrio_nadd and pfrio_nchange contain the number of addresses
             deleted, added and changed by the kernel.  If pfrio_size2 was set
             on entry, pfrio_size2 will point to the size of the buffer used,

             exactly like DIOCRGETADDRS.

     DIOCRGETADDRS struct pfioc_table
             Get all the addresses of a table.  On entry, pfrio_table contains
             the table id and pfrio_buffer[pfrio_size] contains a valid write-
             able buffer for pfr_addr structures.  On exit, pfrio_size con-
             tains the number of addresses written into the buffer.  If the
             buffer was too small, the kernel does not store anything but just
             return the required buffer size, without returning an error.

     DIOCRGETASTATS struct pfioc_table
             Like DIOCRGETADDRS, but returns an array of pfr_astats
             structures.

             struct pfr_astats {
                     struct pfr_addr  pfras_a;
                     u_int64_t        pfras_packets
                                          [PFR_DIR_MAX][PFR_OP_ADDR_MAX];
                     u_int64_t        pfras_bytes
                                          [PFR_DIR_MAX][PFR_OP_ADDR_MAX];
                     long             pfras_tzero;
             };

     DIOCRCLRASTATS struct pfioc_table
             Clears the statistics of one or more addresses.  On entry,
             pfrio_table contains the table id and pfrio_buffer[pfrio_size]
             contains a table of pfr_addr structures to clear.  On exit,
             pfrio_nzero contains the number of addresses effectively cleared.

     DIOCRTSTADDRS struct pfioc_table
             Test if the given addresses match a table.  On entry, pfrio_table
             contains the table id and pfrio_buffer[pfrio_size] contains a
             table of pfr_addr structures to test.  On exit, the kernel up-
             dates the pfr_addr table by setting the pfra_fback member appro-
             priately.

     DIOCRSETTFLAGS struct pfioc_table
             Change the const or persist flag of a table.  On entry,
             pfrio_buffer[pfrio_size] contains a table of pfr_table struc-
             tures, and pfrio_setflag contains the flags to add, while
             pfrio_clrflag contains the flags to remove.  On exit,
             pfrio_nchange and pfrio_ndel contain the number of tables altered
             or deleted by the kernel.  Yes, tables can be deleted if one re-
             moves the persist flag of an unreferenced table.

     DIOCRINABEGIN struct pfioc_table
             Starts a transaction with the inactive set of tables.  Cleans up
             any leftover from a previously aborted transaction, and returns a
             new ticket.  On exit, pfrio_ndel contains the number of leftover
             table deleted, and pfrio_ticket contains a valid ticket to use
             for the following two IOCTLs.

     DIOCRINACOMMIT struct pfioc_table
             Commit the inactive set of tables into the active set.  While
             copying the addresses, do a best effort to keep statistics for
             addresses present before and after the commit.  On entry,
             io->pfrio_ticket takes a valid ticket.  On exit, io->pfrio_nadd
             and io->pfrio_nchange contain the number of tables added and al-
             tered by the commit operation.

     DIOCRINADEFINE struct pfioc_table
             Defines a table in the inactive set.  On entry, pfrio_table con-
             tains the table id and pfrio_buffer[pfrio_size] contains the list
             of pfr_addr structures to put in the table.  A valid ticket must
             also be supplied to pfrio_ticket.  On exit, pfrio_nadd contains 0
             if the table was already defined in the inactive list, or 1 if a
             new table has been created.  pfrio_naddr contains the number of
             addresses effectively put in the table.

EXAMPLES
     The following example demonstrates how to use the DIOCNATLOOK command to
     find the internal host/port of a NATed connection.

     #include <sys/types.h>
     #include <sys/socket.h>
     #include <sys/ioctl.h>
     #include <sys/fcntl.h>
     #include <net/if.h>
     #include <netinet/in.h>
     #include <net/pfvar.h>
     #include <stdio.h>

     u_int32_t
     read_address(const char *s)
     {
             int a, b, c, d;

             sscanf(s, "%i.%i.%i.%i", &a, &b, &c, &d);
             return htonl(a << 24 | b << 16 | c << 8 | d);
     }

     void
     print_address(u_int32_t a)
     {
             a = ntohl(a);
             printf("%d.%d.%d.%d", a >> 24 & 255, a >> 16 & 255,
                 a >> 8 & 255, a & 255);
     }

     int
     main(int argc, char *argv[])
     {
             struct pfioc_natlook nl;
             int dev;

             if (argc != 5) {
                     printf("%s <gwy addr> <gwy port> <ext addr> <ext port>\n",
                         argv[0]);
                     return 1;
             }

             dev = open("/dev/pf", O_RDWR);
             if (dev == -1)
                     err(1, "open(\"/dev/pf\") failed");

             memset(&nl, 0, sizeof(struct pfioc_natlook));
             nl.saddr.v4.s_addr      = read_address(argv[1]);
             nl.sport                = htons(atoi(argv[2]));
             nl.daddr.v4.s_addr      = read_address(argv[3]);
             nl.dport                = htons(atoi(argv[4]));
             nl.af                   = AF_INET;
             nl.proto                = IPPROTO_TCP;
             nl.direction            = PF_IN;

             if (ioctl(dev, DIOCNATLOOK, &nl))
                     err(1, "DIOCNATLOOK");

             printf("internal host ");
             print_address(nl.rsaddr.v4.s_addr);
             printf(":%u\n", ntohs(nl.rsport));
             return 0;
     }

SEE ALSO
     ioctl(2), bridge(4), pflog(4), pfsync(4), pfctl(8)

HISTORY
     The pf packet filtering mechanism first appeared in OpenBSD 3.0.

OpenBSD 3.3                      June 24, 2001                               9