OpenBSD manual page server

Manual Page Search Parameters

VRELE(9) Kernel Developer's Manual VRELE(9)

vreledecrement the use count for a vnode

#include <sys/param.h>
#include <sys/vnode.h>

int
vrele(struct vnode *vp);

Decrement the v_usecount field of the vnode specified by vp.

Any code in the system which uses a vnode should call () when it is finished with the vnode. If the v_usecount field of the vnode reaches zero, the vnode will be placed on the free list.

vrele() returns 0 if it can guarantee that it did not sleep.

vget(9), vnode(9), vput(9), vref(9)

This man page was originally written by Doug Rabson for FreeBSD.

June 4, 2013 OpenBSD-current