OpenBSD manual page server

Manual Page Search Parameters

RL(4) Device Drivers Manual RL(4)

rlRealtek 8129/8139 10/100 Ethernet device

rl* at pci?
rl* at cardbus?
rlphy* at mii?

The rl driver provides support for PCI Ethernet adapters and embedded controllers based on the Realtek 8129 and 8139 Fast Ethernet controller chips. This includes, among others, the following cards:

The Realtek controllers use bus master DMA but do not use a descriptor-based data transfer mechanism. The receiver uses a single fixed size ring buffer from which packets must be copied into mbufs. For transmission, there are only four outbound packet address registers which require all outgoing packets to be stored as contiguous buffers. Furthermore, outbound packet buffers must be longword aligned or else transmission will fail.

The 8129 differs from the 8139 in that the 8139 has an internal PHY which is controlled through special direct access registers whereas the 8129 uses an external PHY via an MII bus. The 8139 supports both 10 and 100Mbps speeds in either full or half duplex. The 8129 can support the same speeds and modes given an appropriate PHY chip.

The rl driver supports the following media types:

autoselect
Enable autoselection of the media type and options. This is only supported if the PHY chip attached to the Realtek controller supports NWAY autonegotiation. The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file.
10baseT
Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes.
100baseTX
Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes.

The rl driver supports the following media options:

full-duplex
Force full duplex operation.
half-duplex
Force half duplex operation.

Note that the 100baseTX media type is only available if supported by the adapter. For more information on configuring this device, see ifconfig(8).

rl0: couldn't map memory
A fatal initialization error has occurred.
rl0: couldn't map interrupt
A fatal initialization error has occurred.
rl0: watchdog timeout
The device has stopped responding to the network, or there is a problem with the network connection (cable).
rl0: no memory for rx list
The driver failed to allocate an mbuf for the receiver ring.
rl0: no memory for tx list
The driver failed to allocate an mbuf for the transmitter ring when allocating a pad buffer or collapsing an mbuf chain into a cluster.

arp(4), ifmedia(4), intro(4), netintro(4), rlphy(4), hostname.if(5), ifconfig(8)

The Realtek 8129 and 8139 datasheets, ftp.realtek.com.tw:/lancard/data sheet.

The rl device driver first appeared in FreeBSD 3.0. OpenBSD support first appeared in OpenBSD 2.5.

The rl driver was written by Bill Paul <wpaul@ctr.columbia.edu>.

Since outbound packets must be longword aligned, the transmit routine has to copy an unaligned packet into an mbuf cluster buffer before transmission. The driver abuses the fact that the cluster buffer pool is allocated at system startup time in a contiguous region starting at a page boundary. Since cluster buffers are 2048 bytes, they are longword aligned by definition. The driver probably should not be depending on this characteristic.

The Realtek data sheets are of especially poor quality: the grammar and spelling are awful and there is a lot of information missing, particularly concerning the receiver operation. One particularly important fact that the data sheets fail to mention relates to the way in which the chip fills in the receive buffer. When an interrupt is posted to signal that a frame has been received, it is possible that another frame might be in the process of being copied into the receive buffer while the driver is busy handling the first one. If the driver manages to finish processing the first frame before the chip is done DMAing the rest of the next frame, the driver may attempt to process the next frame in the buffer before the chip has had a chance to finish DMAing all of it.

The driver can check for an incomplete frame by inspecting the frame length in the header preceding the actual packet data: an incomplete frame will have the magic length of 0xFFF0. When the driver encounters this value, it knows that it has finished processing all currently available packets. Neither this magic value nor its significance are documented anywhere in the Realtek data sheets.

July 16, 2013 OpenBSD-6.1