OpenBSD manual page server

Manual Page Search Parameters

CONFIG_DEFER(9) Kernel Developer's Manual CONFIG_DEFER(9)

config_defer, config_mountrootdeferred device configuration

#include <sys/param.h>
#include <sys/device.h>

void
config_defer(struct device *dev, void (*func)(struct device *));

void
config_mountroot(struct device *dev, void (*func)(struct device *));

The () function is called by the child to defer the remainder of its configuration until all its parent devices have been attached. At this point, the function func is called with the argument dev.

The () function is called by a device driver to defer the remainder of its configuration until after the root file system is mounted. At this point, the function func is called with the argument dev.

December 12, 2015 OpenBSD-current